JS not loading on Preview

VERIFIED FIXED in 5.11.3

Status

VERIFIED FIXED
8 years ago
3 years ago

People

(Reporter: krupa.mozbugs, Assigned: jbalogh)

Tracking

Details

(Whiteboard: [z], URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Created attachment 454168 [details]
screenshot

user agent:Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.4) Gecko/20100611 Firefox/3.6.4

steps to reproduce:
Do a search with advanced options-platform=MACOSX and Sort=Name


observed behavior:
Advanced=on persists and the advanced search panel is open when search returns results.
(Reporter)

Comment 1

8 years ago
I see a bunch of JS errors and all the buttons say "Download Now" instead of "Add to firefox"


Error: JSON.parse(document.body.getAttribute("data-readonly")) is not a function
Source File: https://preview.addons.mozilla.org/media/js/common-min.js?build=19ea1bb
Line: 16

Error: $(".install").installButton is not a function
Source File: https://preview.addons.mozilla.org/media/js/common-min.js?build=19ea1bb
Line: 16

Error: z.button is undefined
Source File: https://preview.addons.mozilla.org/en-US/firefox/addons/buttons.js/build:19ea1bb
Line: 21
Summary: Advanced=on persists while doing search → JS not loading on Preview
(Assignee)

Updated

8 years ago
Depends on: 574836
(Assignee)

Updated

8 years ago
Duplicate of this bug: 574937
(Assignee)

Comment 3

8 years ago
http://github.com/jbalogh/zamboni/commits/035bce7
Assignee: nobody → jbalogh
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

8 years ago
verified
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.