New error message after upgrade (Server returns "NO Mailbox does not exist or must be subscribed to" to STATUS command for existent/non-\Noselect folder)

RESOLVED WORKSFORME

Status

MailNews Core
Networking: IMAP
RESOLVED WORKSFORME
8 years ago
6 years ago

People

(Reporter: bugzilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dupeme?])

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US) AppleWebKit/533.4 (KHTML, like Gecko) Chrome/5.0.375.70 Safari/533.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.4) Gecko/20100608 Lightning/1.0b2 Thunderbird/3.1

Had 3 accounts set up on Thunderbird.  Everything was working.  Upgraded to 3.1.  Now getting errors on 1 of the 3 accounts.  "The current command did not succeed.  Them mail server for account xxxxxxxx responded: Mailbox does not exist, or must be subscribed to."  All accounts are on the same server (VPS) and no configuration changes were made to any of them.

Reproducible: Always

Steps to Reproduce:
1.Happens whenever Thunderbird checks for mail on that account.  Mail loads but error message pops up (gets logged in Activity Manager)
2.
3.
Actual Results:  
Open Thunderbird and have it check for email on the three accounts.  Generates error on one of the three accounts.  Still loads email from all three accounts.

Expected Results:  
Expect Thunderbird to load email messages without generating an error unless there is a problem.  Expect error message to pinpoint the problem.
Similar phenomen to bug 574521?
(Reporter)

Comment 2

8 years ago
I would say yes, similar.
(Reporter)

Comment 3

8 years ago
Comment posted under bug 574521:
If you uncheck the box for checking the email, doesn't that defeat the purpose of Thunderbird as an email client?  Why would you want an email account set up to NOT check for email?  Maybe I'm missing something.  Also, I tried this fix and still got error messages, which really surprised me.  If it's not checking for email, why would it generate an error saying an unspecified command resulted in some reply from a mail server?  I'm baffled.  The only thing I'm sure of is that before the upgrade to 3.1 I was not seeing these errors.
(In reply to comment #3)

If same as bug 574521, problematic folder is folder which can't hold mail. 
dave@dww1105.com, why do you need to check for new messages of an IMAP folder which can't hold mail in it?
"Unchecking of the option" probably requires restart of Tb(AFAIR, known bug).
(Reporter)

Comment 5

8 years ago
(In reply to comment #4)
> (In reply to comment #3)
> 
> If same as bug 574521, problematic folder is folder which can't hold mail. 
> dave@dww1105.com, why do you need to check for new messages of an IMAP folder
> which can't hold mail in it?
> "Unchecking of the option" probably requires restart of Tb(AFAIR, known bug).

Unless I'm missing something, I do not have any folders that do not accept email checked.  As stated, nothing was changed from prior to the upgrade when it worked, and I have two accounts that do not appear to be throwing errors that have the same file structure as the one that is throwing errors (after the upgrade).  I restart TB when I make any changes in order to see if it solves the problem....no luck so far.
(Reporter)

Comment 6

8 years ago
Just noticed that TB is inserting an INBOX subfolder under the problematic account main folder.  There is no checkbox for that INBOX subfolder but there is also a sub-subfolder TRASH that has a checkbox.  However, unchecking that sub-subfolder does not cure the problem.  Also, deleting those folders does not work and they are reinserted upon restarting TB.  The two accounts that do not generate an error do not have the INBOX subfolder.

Comment 7

8 years ago
Created attachment 454342 [details]
IMAP LOG demonstrating the problem

In my case I am getting this because I seem to have a mbox file inside my maildir that I don't yet know why it's there. 

betelgeuse@woodpecker ~/.maildir $ file .lists.li
.lists.linux-packaging/ .lists.list             .lists.lists/

At the very least the error message should tell the user what folder it's about so in case it's a server side problem they can fix it.
> 48 STATUS "INBOX.lists.list" (UIDNEXT MESSAGES UNSEEN RECENT)
> 48 NO Mailbox does not exist, or must be subscribed to.

Important thing is attribute returned to LIST/XLIST/LSUB command for INBOX.lists.list and Folder Properties of Inbox->lists->list for new mail check.
Read already pointed bug 574521, please.

> In my case I am getting this because I seem to have a mbox file inside my
maildir
> that I don't yet know why it's there. 

It's simply because your settings/operations asked Tb to access the IMAP folder and to do someting on the IMAP folder(new mail check, if same as bug 574521). And, "which directory/file is used for an IMAP folder" is up to IMAP server. IMAP mail client(Tb) is absolutely irrelevant to the location of directory/file.
Check your folder related settings such as subscription status, Server Settings/Avanced (and Delete model and Trash choice, Junk folder choice, Folder choice at Copies and Folders etc.). Check namaspace repsponse from your server too.

> At the very least the error message should tell the user what folder it's
> about so in case it's a server side problem they can fix it.

Known issue and enhancement is already requested. Search B.M.O by yourself via "Advanced Search", please. Keep "one problem per a bug", please.

Comment 9

8 years ago
(In reply to comment #8)
> 
> Known issue and enhancement is already requested. Search B.M.O by yourself via
> "Advanced Search", please. Keep "one problem per a bug", please.

Shouldn't this be closed as a duplicate then?
(Reporter)

Comment 10

8 years ago
I think I've narrowed it down to the synchronization method chosen in the migration assistant.  If I choose Synchronize, I get the error.  If I choose either Do Not Synchronize or Per Account Synchronization, I do not get the error (at least so far).
dave@dww1105.com:
Can you open and see mails in folder of the Inbox->lists->list?
Can you copy a mail to the Inbox->lists->list? 
Can you see your problem again by change of next settings?
  Folder Properties of Inbox->lists->list :
    (a) Synchronization, offline use = on / off
    (b) General, option to check new message = on / off

Similar problem to bug 547783(same error message text from server as yours for SELECT, because folder really doesn't exist at server) rather than bug 574521(folder of \Noselect)?
(Reporter)

Comment 12

8 years ago
WADA, I'm not sure what you mean by Inbox->lists->list but if you mean a subfolder under the Inbox, yes, I can open and read email in the subfolders.  Under the properties tab for the inbox, I do not see the option to check new messages (I do see that under Tools->Account Settings->Server Settings).
(In reply to comment #12)

You are right. "->" == has subfolder of.

> Under the properties tab for the inbox, I do not see the option to check new messages

It seems because of subfolder of Inbox.
How about Trash? trash is Inbox.Trash(namespace=INBOX.)?

> but if you mean a subfolder under the Inbox, yes, I can open and read email in the subfolders. 

It means that the folder is not folder of \Noselect. Probably issue with STATUS only. Server probably returns NO to STATUS, because folder level lock(lock od DB for mail data) can not be obtained when STATUS is requested. It can occur on some IMAP servers when Web mail service is also provided.
Option to ignore NO to STATUS is required?
Component: General → Networking: IMAP
Product: Thunderbird → MailNews Core
QA Contact: general → networking.imap
(Reporter)

Comment 14

8 years ago
Web mail service is provided on my mail server.  How do I select Option to ignore NO to STATUS?
(In reply to comment #14)
> How do I select Option to ignore NO to STATUS?

Oh, sorry for unclear question to myself.
As seen in your case, some servers returns NO to STATUS command even if the IMAP folder doesn't have \Noselect attribute and IMAP server returns OK to SELECT.
Currently found problems are;
  - If such folder is subfolder of INBOX, it doesn't seem that there is a way
    to prohibit new mail checking via option of Folder Properties.
    (This bug unique issue)
  - In such case, Tb3.0 showed error in Activity Manager only.
    However, Tb 3.1 or later shows alert upon each "NO to STATUS",
    and it's very annoying for users.
    (Common issue with bug 574521)

What is best solution in your case do you think?
(Reporter)

Comment 16

8 years ago
(In reply to comment #15)
>
> What is best solution in your case do you think?

I ended up leaving synchronization turned off.  Plan B would be to find another email client that includes a calendar.  So far I don't like any of the alternatives.
(In reply to comment #12)
> Under the properties tab for the inbox, I do not see the option to check new messages

You talked about Inbox. Inbox doesn't have option for "include this folder when new mail check", because Inbox is always included if "check for new message" is enabled.
I asked the option setting for INBOX.lists.list on which problem occurred.
Summary: New error message after upgrade (Mailbox does not exist or must be subscribed to) → New error message after upgrade (Server returns "NO Mailbox does not exist or must be subscribed to" to STATUS command for existent/non-\Noselect folder)
FYI.
Bug 577343 is for "repeated slide-in alert" part, and has been fixed(fixed by Tb 3.1.1).
Depends on: 577343

Comment 19

6 years ago
dww1105, can you still reproduce this problem?

And if so, please generate an imap log (https://wiki.mozilla.org/MailNews:Logging) and attach the log to this bug 

It has been suggested this bug is a duplicate of Bug 497806 - Thunderbird looks for folder INBOX./Sent (when IMAP server directory: INBOX. is set and NAMESPACE command use is prohibited by user
Whiteboard: [dupeme?]
(Reporter)

Comment 20

6 years ago
Wayne, I am now using Thunderbird 10 and do not have this issue.

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.