Please create Web page Firefox Home 1.0 Release Notes

VERIFIED FIXED

Status

--
critical
VERIFIED FIXED
9 years ago
6 years ago

People

(Reporter: clooney, Assigned: sgarrity)

Tracking

({verified-production})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
Below are the release notes to follow a similar structure as Mobile 1.0.1 rel notes https://www-trunk.stage.mozilla.com/en-US/mobile/1.0.1/releasenotes/


Firefox Home 1.0 for iPhone Release Notes

v.1.0, released June XX, 2010


Get up and go and have everything waiting for you on your iPhone: Your Firefox history, bookmarks and open tabs, just as you had left them on your desktop.
Learn how we're bringing parts of the Firefox experience to mobile devices. Check out the features, known issues and frequently asked questions about Firefox Home 1.0 for the iPhone and iPod Touch. As always, you’re encouraged to tell us what you think, ask a question, or file a bug in Bugzilla.
What's in Firefox Home 1.0 Application

For devices or platforms where we're unable to provide the "full" Firefox browser (either technically or due to policy), Firefox Home aims to provide users part of the Firefox experience with "on the go" instant access to their personal Firefox history, bookmarks and open tabs on their iPhone or iPod Touch.


Firefox Home is built upon open, simple and powerful REST APIs that you can use for your own applications! The User API enables account creation, authentication and other account-related actions. The Sync API handles data storage and retrieval. These APIs work hand-in-hand to provide a complete end-to-end synchronization service. All of our code is open source, including that for the server, which means you can even run your own servers if you want.

For more information about Firefox Home, check out our progress, updates and FAQ here.

Highlights include:

    * One-way refresh of your Firefox desktop history, bookmarks and open tabs to your iPhone or iPod Touch
    * Instant access to your open tabs, just the way you left them on your PC
    * Awesome Bar Search to get you to your recently and frequently visited sites with minimal typing
    * Instant access to your bookmarks to get you to important sites by tapping instead of typing
    * End-to-end encryption so only you have access to your Firefox data
    * Access to your Settings to see what data has been ported, as well as the option to Refresh at any time


System Requirements

You must have a Firefox Sync account to set up and use Firefox Home on your iPhone. You must have a Apple iPhone or Apple iPod Touch to use Firefox Home. 
Downloading

Download Firefox Home directly from your iPhone or iPod Touch, or by visiting the iTunes Store. You can also go to Firefox.com/mobile/home to download, get Setup instructions and learn more about the features and benefits of Firefox Home for the iPhone.
Known Issues

    * Firefox Home does not sync activity back from the iPhone to the cloud. It currently does a one-way sync of your data from the cloud to the iPhone.
    * Firefox Home provides you with your Firefox desktop history, bookmarks and open tabs. It does not provide you with passwords that you might have stored on your desktop.
    * First Web page selection doesn't load Bug 567457 -- Should be fixed in RC 1, remove if confirmed fixed.
    * Firefox Home does not support using Unicode characters in your Secret Phrase.




Frequently Asked Questions

About Firefox Home

1. What is Firefox Home?

Firefox Home is a free application that lets you have access to your Firefox desktop history, bookmarks and open tabs on your iPhone.

2. Does this mean Firefox will be available on the iPhone?

No. We do not have plans to ship the Firefox browser for the iPhone. Due to constraints with the OS environment and distribution, we cannot provide users Firefox for the iPhone.

3. What happened to Weave Sync?

The "Weave Sync" project from Mozilla Labs has officially graduated and is now being incorporated into the Firefox roadmap.
See http://blog.mozilla.com/blog/2010/06/16/your-firefox-in-the-cloud-firefox-sync-and-firefox-home/ for more details.

4. What is the difference between Firefox Sync and Firefox Home?

Firefox Home is a native iPhone application that does a one-way data refresh of your Firefox history, bookmarks and open tabs to your iPhone, whereas Firefox Sync is an add-on for Firefox that does a two-way sync of a user's Firefox history, bookmarks, open tabs and saved passwords between their desktop and Firefox mobile-enabled devices. Learn more about their functions, similarities and differences here.

5. How does the viewer in Firefox Home work?

The integrated Web viewer uses the native iPhone webview capability. Alternatively, you can also open any link in Safari.

6. How is Firefox Home licensed?

Firefox Home is licensed under the MPL.

7. I am having issues with Firefox Home. How do I troubleshoot?

Please visit the the Firefox Home Support page.

Security

1. How is my data protected?

Your information is encrypted and stored in the Mozilla servers. Only you can access data with your Secret Phrase. Firefox puts security as a top priority and syncing is no exception. Learn more about this and see a diagram here.

Downloading & Devices

1. How do I setup the Firefox Home app?

Follow these simple steps located on the Firefox Home Support page.

2. Why do I need a Firefox Sync account to install Firefox Home?

Firefox Home uses the sync capabilities from the Firefox Sync add-on to access your Firefox browser information and securely send it to your iPhone.

3. What platforms and devices will it be available for?

Firefox Home has currently been developed for all generations of Apple iPhone and Apple iPod Touch.

4. What about an iPad version?

Firefox Home 1.0 for the iPhone will work on the iPad, but it is not optimized for the iPad.

Using Firefox Home

1. How do I know what data is available on my iPhone?

Go to your Settings tab to see your bookmarks, tabs and history entries that have been brought over to your iPhone. You can refresh your data by tapping the Refresh button.

Features

1. What are the main features of Firefox Home?

Get up and go and have exactly what you're looking for waiting on your iPhone: Your Firefox history, bookmarks, open tabs, Awesome Bar -- just the way you
left it on your desktop. With Firefox Home, you'll never have to retype long and painful URLs or spend time searching for your favorite websites. You can even send these links to friends via email.  All of your data is encrypted. Your Secret Phrase ensures that only you have access to your data.

Developer Questions
1. What is the technology platform that powers Firefox Home?

Like Firefox Sync, Firefox Home is built on an open, simple and powerful set of REST APIs that you can use for your own applications. The User API enables account creation, authentication and other account-related actions. The Sync API handles data storage and retrieval. These APIs work hand-in-hand to provide a complete end-to-end synchronization service. All of our code is open source, including that for the server, which means you can even run your own servers if you want.

*This page also needs to link from https://www-trunk.stage.mozilla.com/en-US/mobile/home/

Thanks!
(Reporter)

Comment 1

9 years ago
(In reply to comment #0)

--Added a one new known issues and new FAQ with changes throughout. 



> Below are the release notes to follow a similar structure as Mobile 1.0.1 rel
> notes https://www-trunk.stage.mozilla.com/en-US/mobile/1.0.1/releasenotes/
> 
> 
> Firefox Home 1.0 for iPhone Release Notes
> 
> v.1.0, released June XX, 2010
> 
> 
> Get up and go and have everything waiting for you on your iPhone: Your Firefox
> history, bookmarks and open tabs, just as you had left them on your desktop.
> Learn how we're bringing parts of the Firefox experience to mobile devices.
> Check out the features, known issues and frequently asked questions about
> Firefox Home 1.0 for the iPhone and iPod Touch. As always, you’re encouraged to
> tell us what you think, ask a question, or file a bug in Bugzilla.
> What's in Firefox Home 1.0 Application
> 
> For devices or platforms where we're unable to provide the "full" Firefox
> browser (either technically or due to policy), Firefox Home aims to provide
> users part of the Firefox experience with "on the go" instant access to their
> personal Firefox history, bookmarks and open tabs on their iPhone or iPod
> Touch.
> 
> 
> Firefox Home is built upon open, simple and powerful REST APIs that you can use
> for your own applications! The User API enables account creation,
> authentication and other account-related actions. The Sync API handles data
> storage and retrieval. These APIs work hand-in-hand to provide a complete
> end-to-end synchronization service. All of our code is open source, including
> that for the server, which means you can even run your own servers if you want.
> 
> For more information about Firefox Home, check out our progress, updates and
> FAQ here.
> 
> Highlights include:
> 
>     * One-way refresh of your Firefox desktop history, bookmarks and open tabs
> to your iPhone or iPod Touch
>     * Instant access to your open tabs, just the way you left them on your PC
>     * Awesome Bar Search to get you to your recently and frequently visited
> sites with minimal typing
>     * Instant access to your bookmarks to get you to important sites by tapping
> instead of typing
>     * End-to-end encryption so only you have access to your Firefox data
>     * Access to your Settings to see what data has been ported, as well as the
> option to Refresh at any time
> 
> 
> System Requirements
> 
> You must have a Firefox Sync account to set up and use Firefox Home on your
> iPhone. You must have a Apple iPhone or Apple iPod Touch to use Firefox Home.
 
> Downloading
> 
> Download Firefox Home directly from your iPhone or iPod Touch, or by visiting
> the iTunes Store. You can also go to Firefox.com/mobile/home to download, get
> Setup instructions and learn more about the features and benefits of Firefox
> Home for the iPhone.

> Known Issues
> 
>     * Firefox Home does not sync activity back from the iPhone to the cloud. It
> currently does a one-way sync of your data from the cloud to the iPhone.
>     * Firefox Home provides you with your Firefox desktop history, bookmarks
> and open tabs. It does not provide you with passwords that you might have
> stored on your desktop.
>     * First Web page selection doesn't load Bug 567457 -- Should be fixed in RC
> 1, remove if confirmed fixed.
>     * Firefox Home does not support using Unicode characters in your Secret
> Phrase.
> *Firefox Home works on older devices, but the experience won't be as awesome as it would on a 3G or 3GS
> 
> 
> 
> Frequently Asked Questions
About Firefox Home
1. What is Firefox Home?

Firefox Home is a free application that lets you have access to your Firefox desktop history, bookmarks and open tabs on your iPhone.

2. Does this mean Firefox will be available on the iPhone?

No. We do not have plans to ship the Firefox browser for the iPhone. Due to constraints with the OS environment and distribution, we cannot provide users Firefox for the iPhone.

3. What happened to Weave Sync?

The "Weave Sync" project from Mozilla Labs has been renamed to Firefox Sync and is now being incorporated into the Firefox roadmap. See http://blog.mozilla.com/blog/2010/06/16/your-firefox-in-the-cloud-firefox-sync-and-firefox-home/ for more details.

4. What is the difference between Firefox Sync and Firefox Home?

Firefox Home is a native iPhone application that does a one-way data refresh of your Firefox history, bookmarks and open tabs to your iPhone, whereas Firefox Sync is an add-on for Firefox that does a two-way sync of a user's Firefox history, bookmarks, open tabs and saved passwords between their desktop and Firefox mobile-enabled devices. Learn more about their functions, similarities and differences here.

5. How does the viewer in Firefox Home work?

The integrated Web viewer uses the native iPhone webview capability. Alternatively, you can also open any link in Safari.

6. Is all of my Firefox history synced to the iPhone? If not, how much of it?

We sync the 2000 most frequently or recently visited history items every 24 hours. In the interim, we tack on any history changes within that period.

7. How often is the data synced to my iPhone?

 Data is synced to the phone every time you launch the app. We currently do not auto-sync as the most common use case is a launch-use-quit scenario, especially in the predominantly single-tasking world of apps on the iPhone. Users always have the option of forcing a refresh from the Settings tab.

8. Does it sync efficiently? I don't have an unlimited data plan for my iPhone. Should I be concerned?
We only sync changes since the last update for bookmarks and open tabs. And history is limited to about 2000 items. And there is no auto-sync. The median disk space used by Sync users is about 2-3 MB total for all of their Sync data and Home only has a subset of that.


9. How is Firefox Home licensed?

Firefox Home is licensed under the MPL.

10. I am having issues with Firefox Home. How do I troubleshoot?

Please visit the the Firefox Home Support page.

Security

1. How is my data protected?

Your information is encrypted and stored in the Mozilla servers. Only you can access data with your Secret Phrase. Firefox puts security as a top priority and syncing is no exception. Learn more about this and see a diagram here.

2. What is the secret phrase for?
The secret phrase is used to encrypt/decrypt all of your data on your clients. This ensures that your data is only ever accessible to you and all that the server stores is an encrypted block of data.

3. What encryption algorithm does Sync use? Is it proven to be secure?
Sync uses the AES encryption algorithm with a 256 bit key in a mode that requires an initialization vector for every decryption. Additionally, all client server communications are over SSL. The cryptography we use is in compliance with NIST requirements.


Downloading & Devices

1. How do I setup the Firefox Home app?

Follow these simple steps located on the Firefox Home Support page.

2. Why do I need a Firefox Sync account to install Firefox Home?

Firefox Home uses the sync capabilities from the Firefox Sync add-on to access your Firefox browser information and sends it to the cloud, where it is accessed from your iPhone.
3. What platforms and devices will it be available for?

Firefox Home has currently been developed for all generations of Apple iPhone and Apple iPod Touch. Although it works on older devices, the experience won't be as awesome as it is on 3G or 3GS.

4. What about an iPad version?

Firefox Home 1.0 for the iPhone will work on the iPad, but it is not optimized for the iPad.

5. How does it work with iPhone 4.0 / iOS 4.0? Does it take advantage of multi-taksing? Will it sync in the background?

Home works on both iPhone 4.0 and iOS 4.0. However, as with any new technology (in this case both h/w and s/w), we should expect to learn more about the platform quirks with more adoption. Home currently does not take advantage of multi-tasking. It currently does not sync in the background either.

Using Firefox Home

1. How do I know what data is available on my iPhone?

Go to your Settings tab to see your bookmarks, tabs and history entries that have been brought over to your iPhone. You can refresh your data by tapping the Refresh button.

Features

1. What are the main features of Firefox Home?

Get up and go and have exactly what you're looking for waiting on your iPhone: Your Firefox history, bookmarks, open tabs, Awesome Bar -- just the way you
left it on your desktop. With Firefox Home, you'll never have to retype long and painful URLs or spend time searching for your favorite websites. You can even send these links to friends via email.  All of your data is encrypted. Your Secret Phrase ensures that only you have access to your data.

Developer Questions
1. What is the technology platform that powers Firefox Home?

Like Firefox Sync, Firefox Home is built on an open, simple and powerful set of REST APIs that you can use for your own applications. The User API enables account creation, authentication and other account-related actions. The Sync API handles data storage and retrieval. These APIs work hand-in-hand to provide a complete end-to-end synchronization service. All of our code is open source, including that for the server, which means you can even run your own servers if you want.
(Reporter)

Updated

9 years ago
Severity: major → critical
Assignee: abuchanan → steven
(Assignee)

Comment 2

9 years ago
This page is setup in trunk in r69769.

Preview here: http://www-trunk.stage.mozilla.com/en-US/mobile/home/1.0/releasenotes/

A few questions:

Is there a list of the links that should be in the text?

Are all the of the "FAQ" lists supposed to be under the single Frequently Asked Questions title - or do they go in their own sub-sections?
(Reporter)

Comment 3

9 years ago
(In reply to comment #2)
> This page is setup in trunk in r69769.
> 
> Preview here:
> http://www-trunk.stage.mozilla.com/en-US/mobile/home/1.0/releasenotes/
> 
> A few questions:
> 
> Is there a list of the links that should be in the text? Yes, there are a lot of links that need to be incorporated, that is why I pointed Alex to the gdoc. Would you like me to list them out in chrono? I can also share the gdoc with you so you can see yourself: https://docs.google.com/Doc?docid=0ARRF0upBv6naZGhkeG5najhfNDc4ejV4bmtreg&hl=en
> 
> Are all the of the "FAQ" lists supposed to be under the single Frequently Asked
> Questions title - or do they go in their own sub-sections?
(Assignee)

Comment 4

9 years ago
Links added to the release notes in r69794.
(Reporter)

Comment 6

9 years ago
This is coming along, thanks Steven! Currently the FAQ link on the Firefox Home landing page links to N900 rel notes and the Release Notes in the main mobile nav point to Firefox Home Rel notes -- can we reverse the two?

As Stephen Donner pointed out, the Downloading section of Rel Notes seems to be busted and links straight to a Sync page.

Under System Requirements, most of the content is linked. I believe just Firefox Sync should be linked.

Under Known Issues, the last bullet is missing: "Firefox Home works on older devices, but the experience won't be as awesome as it would on a 3G or 3GS"

Thanks!
(Reporter)

Comment 7

9 years ago
Also, please remove "First Web page doesn't load" from Known Issues list. This bug has been fixed. Thanks~
(Assignee)

Comment 8

9 years ago
Fixed broken validation issues from comment #5 and the content updates from comments #6 and #7 in r69821. Please confirm.

Comment 9

9 years ago
Can we change the link in this section:

What happened to Weave Sync?
    The "Weave Sync" project from Mozilla Labs has been renamed to Firefox Sync and is now being incorporated into the Firefox roadmap. See this blog post for more details.

to point to:
http://mozillalabs.com/blog/2010/06/firefox-sync-graduates-from-mozilla-labs/

We also need to add another question to address availability in only certain regions. We'll add that in a comment soon.
Can we please change this:

What encryption algorithm does Sync use? Is it proven to be secure?
Sync uses the AES encryption algorithm with a 256 bit key in a mode that requires an initialization vector for every decryption. Additionally, all client server communications are over SSL. The cryptography we use is in compliance with NIST requirements.

to:

What encryption algorithm do Firefox Home and Firefox Sync use? Is it proven to be secure?

Firefox Home and Firefox Sync use the AES encryption algorithm with a 256 bit key in a mode that requires an initialization vector for every decryption. Additionally, all client server communications are over SSL. The cryptography we use is in compliance with NIST requirements.
(Assignee)

Comment 11

9 years ago
Changes from comment #9 and comment #10 are addressed in r69822.
(Reporter)

Comment 12

9 years ago
In System Requirements sections, there should an "an" instead of "a" before Applie iPhone or iPod Touch.
(Reporter)

Comment 13

9 years ago
(In reply to comment #11)
> Changes from comment #9 and comment #10 are addressed in r69822.

These comments are in the Rel Notes bug but meant for the FAQ. I moved them over to the FAQ bug.
(Assignee)

Comment 14

9 years ago
(In reply to comment #12)
> In System Requirements sections, there should an "an" instead of "a" before
> Applie iPhone or iPod Touch.

Fixed in r69842.
(Reporter)

Comment 15

9 years ago
We have one more Known Issues to add to the bottom of the bulleted list:

"Those who use Firefox Home on an iPhone 3G, 1st or 2nd generation iPod Touch device that have more than 2000 bookmarks may cause the app to run out of memory"

We have one more statement to add to the System Requirements:

"Firefox Home requires OS 3.1 or higher"

Thanks!
r69863 on trunk
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Verified FIXED (functionality, browser testing, doctype, link validation) on http://www-trunk.stage.mozilla.com/en-US/mobile/home/1.0/releasenotes/.

I didn't check content changes.
Status: RESOLVED → VERIFIED
Keywords: push-needed
OS: Mac OS X → All
Hardware: x86 → All
r69865 on production
Keywords: push-needed
Component: www.mozilla.org/firefox → www.mozilla.org
Product: Websites → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.