JavaScript in Features section doesn't show links

RESOLVED WORKSFORME

Status

()

Core
DOM: Core & HTML
P3
normal
RESOLVED WORKSFORME
17 years ago
17 years ago

People

(Reporter: Jeremy Witt, Assigned: jst)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.73 [en] (X11; U; Linux 2.2.14 i686)
BuildID:    2000101015

When viewing The Onion I noticed that the options in Features box (which is a
javascript)

here's the call:

<A HREF="javascript:onion_pop('http://www.theonion.com/onion3637/infograph_3637$
<NOSCRIPT><A HREF="infograph_3637.html" TARGET="_top"></NOSCRIPT>
are implemented with java script function) do not provide a clickable object to
get the window:

here's the java script function:

<SCRIPT LANGUAGE="JavaScript"> <!-- 
{
self.focus()
}
// --> <!-- Begin
function onion_pop(URL,pop_feature,pop_width,pop_height) {
eval("window.open(URL,'"+pop_feature+"','toolbar=0,scrollbars=1,location=0,statusbar=0,menubar=0,resizable=1,left=10,top=10,"+pop_width+","+pop_height+"');");
}
// End --> </script>




Reproducible: Always
Steps to Reproduce:
1. goto www.theonion.com
2.
3.

Actual Results:  no links to click on in Features box. click on one does nothing

Expected Results:  clicking on link in feature box brings up new
window

Comment 1

17 years ago
over to DOM
Assignee: asa → jst
Status: UNCONFIRMED → NEW
Component: Browser-General → DOM Level 0
Ever confirmed: true
QA Contact: doronr → desale
(Assignee)

Updated

17 years ago
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 2

17 years ago
Looks like this is working fine now, markign WORKSFORME, please reopen if
there's still a problem...
You need to log in before you can comment on or make changes to this bug.