multiple problems with titlebar with new theme, esp. w/persona

RESOLVED INVALID

Status

()

RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: vlad, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Clean profile, default theme, Jun 26 Nightly.

First start:

http://content.screencast.com/users/vvuk/folders/Jing/media/1785139a-fdd7-48c5-a9f0-a3d913a8f197/2010-06-26_1154.png

Looks mostly good, though notice that "Go to a new web site", "Google", and the tab favicon have a thick bottom line, like it's being duplicated.  Resizing the window vertically fixed it.  (Also note the background window which is missing rounded top left/top right corners -- I suspect this is tree style tab's fault, though.)

After a persona is installed:

http://content.screencast.com/users/vvuk/folders/Jing/media/3e40b056-76d1-4fb6-9bea-36028df5b638/2010-06-26_1202.png

Note that the persona covers up the window buttons in the top right, but they're still there and active -- just being drawn underneath.  Hovering over the close button still makes it glow red, and you can see its right side peeking through.

There's also a 1px thick line on the inside of the window border on the right side of the toolbar -- not sure why this happened, but the window currently thinks that it's in "Tabs on Top" mode.  When I unchecked that, nothing changed except that that line went away.

Real tabs on top with persona:

http://www.screencast.com/users/vvuk/folders/Jing/media/4257b924-ca5e-4545-a330-def8467d8ad5

partially opaque tabs, but translucent toolbar background looks weird, especially the 1px thin border dividing the two.  Also note the alignment issues with the persona and the content area -- the content area is 2-3px wider on either side than the persona, and sticks out.  Also jaggy back button, but I think that's known.
Dunno if it's related, but I see http://screencast.com/t/OGQ5NDdhMz
(In reply to comment #1)
> Dunno if it's related, but I see http://screencast.com/t/OGQ5NDdhMz

Hm, you mean the cut-off minefield button at the top?  Could very well be -- it looks like there's some confusion about dimensions/window sizes.
One more -- after disabling the persona above (by enabling the default theme):

http://www.screencast.com/users/vvuk/folders/Jing/media/aa05c004-5a25-4f1b-b544-3325201675d7

Note a) the thick black borders around the tabs; they go away when I hover over the tab; and b) tabs went back on bottom again, even though Tabs on Top is still checked.
Oh, and lack of glass in title bar
(Which could well be because it thinks it's in tabs on top mode [the lack of glass].)  Switching back and forth causes glass to reappear correctly behind the toolbar when it's in "real" tabs on bottom mode, but the thick black borders around the tabs keep appearing whenever I switch.
We really need separate bugs on these issues, I think.
> After a persona is installed:
> 
> http://content.screencast.com/users/vvuk/folders/Jing/media/3e40b056-76d1-4fb6-9bea-36028df5b638/2010-06-26_1202.png
> 
> Note that the persona covers up the window buttons in the top right, but
> they're still there and active -- just being drawn underneath.  Hovering over
> the close button still makes it glow red, and you can see its right side
> peeking through.

bug 574833

> There's also a 1px thick line on the inside of the window border on the right
> side of the toolbar -- not sure why this happened, but the window currently
> thinks that it's in "Tabs on Top" mode.  When I unchecked that, nothing changed
> except that that line went away.

bug 574739

Comment 8

8 years ago
(In reply to comment #2)
> (In reply to comment #1)
> > Dunno if it's related, but I see http://screencast.com/t/OGQ5NDdhMz
> 
> Hm, you mean the cut-off minefield button at the top?  Could very well be -- it
> looks like there's some confusion about dimensions/window sizes.

Bug 574821

Personas generally is not very friendly yet with the new titlebar. Due to an unfortunate quirk in the dwm, caption buttons are rendered to the frame before client content. We'll likely have to paint our own dwm buttons on top to make it work. This applies to coloring the glass for privacy mode as well.

Comment 10

8 years ago
(In reply to comment #9)
> Vlad or Jim/Dao, can we get individual bugs filed about:
> 
> > http://content.screencast.com/users/vvuk/folders/Jing/media/1785139a-fdd7-48c5-a9f0-a3d913a8f197/2010-06-26_1154.png

Will file, FWIW, WFM.

> 
> and
> 
> > http://www.screencast.com/users/vvuk/folders/Jing/media/4257b924-ca5e-4545-a330-def8467d8ad5
> 
> since the others have all been dup'd off?

This is a dupe of the caption buttons personas bug (bug 574833).

Comment 12

8 years ago
filed in various other bugs.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
blocking2.0: ? → ---
You need to log in before you can comment on or make changes to this bug.