[BiDi] valid charset strings for Hebrew

RESOLVED FIXED

Status

()

P3
normal
RESOLVED FIXED
18 years ago
10 years ago

People

(Reporter: bobj, Assigned: mkaply)

Tracking

({intl})

Trunk
x86
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Need to support valid charset strings for visual Hebrew.

Currently Mozilla supports "iso-8859-8-i"

This sample page, http://www.qsm.co.il/Hebrew/HebrewTest/MishneTora13.htm,
uses "iso-8859-8i"

ftp://ftp.isi.edu/in-notes/iana/assignments/character-sets lists:
"iso_8859-8-i" and "csiso88598i"
For "visual" read "logical" or "implicit" (that's what the i stands for).
The charset for visual Hebrew is iso-8859-8 without the i.

Comment 2

18 years ago
Reassign to mkaply@us.ibm.com.

Comment 3

18 years ago
Reassign to mkaply@us.ibm.com.
Assignee: nhotta → mkaply
(Reporter)

Comment 4

18 years ago
Whoops, yes the original comment should have said implicit/logical Hebrew.

But, we should generalize this bug for both visual and logical.  I suspect 
the same issues apply for visual.  We should make sure Mozilla supports the
appropriate charset strings for both visual and logical Hebrew.

Updated summary field to reflect this.
Summary: valid charset strings for visual Hebrew → valid charset strings for Hebrew

Comment 5

18 years ago
*** Bug 57503 has been marked as a duplicate of this bug. ***

Comment 6

18 years ago
*** Bug 57503 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Keywords: intl

Comment 7

18 years ago
Changed QA contact to andreasb@netscape.com.
QA Contact: teruko → andreasb
(Assignee)

Comment 8

18 years ago
See 
http://lxr.mozilla.org/seamonkey/source/intl/uconv/src/charsetalias.properties#2
21

This bug is already fixed
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Updated

18 years ago
Summary: valid charset strings for Hebrew → [BiDi] valid charset strings for Hebrew

Updated

17 years ago
Component: Internationalization → BiDi Hebrew & Arabic

Comment 9

17 years ago
Changing QA contact to default Bidi-Hebrew owner giladehven@hotmail.com.
QA Contact: andreasb → giladehven

Updated

10 years ago
Component: Layout: BiDi Hebrew & Arabic → Layout: Text
QA Contact: giladehven → layout.fonts-and-text
You need to log in before you can comment on or make changes to this bug.