The new UI's main menu (the Minefield menu) is missing a few items

RESOLVED INVALID

Status

()

Firefox
Menus
RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: am, Unassigned)

Tracking

({polish, ue})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a6pre) Gecko/20100626 Minefield/3.7a6pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a6pre) Gecko/20100626 Minefield/3.7a6pre

There are a few things missing in Minefield's main menu, which was available in the old menu bar UI. Firstly, the new Minefield menu should contain the option to allow the user to check for updates; an "About Minefield" option should also be included, which allows the user to check which build of Minefield they have. The "Minefield" menu also contains a "New Window" option, but it should also have a "New tab", and "Enter Private Browsing" option to make it even more accessible to users. A "View Downloads" option should also be available in the Minefield menu. In the customization section of the Minefield menu, the user does not have the option to remove the status bar, which is an option that the user might want to customize.     

Reproducible: Always

Updated

8 years ago
Blocks: 556174
(Reporter)

Updated

8 years ago
Keywords: polish, ue

Comment 1

8 years ago
Resolving this as invalid since it covers multiple issues and I'm almost positive a separate bug exists for each entry that was suggested in this bug.

am: please see this dependency list to see bugs that were filed about the Firefox button. https://bugzilla.mozilla.org/showdependencytree.cgi?id=556174&hide_resolved=1
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.