Closed Bug 57507 Opened 24 years ago Closed 22 years ago

dialogs doesn't accept keyboard input for a short time the first time it's opened

Categories

(Core :: DOM: UI Events & Focus Handling, defect, P3)

defect

Tracking

()

VERIFIED DUPLICATE of bug 55015
Future

People

(Reporter: jruderman, Assigned: saari)

Details

(Keywords: helpwanted)

1. Open a fresh instance of Mozilla
2. Ctrl-L, and very quickly type a letter

Result: Open Web Location dialog with empty textbox
Expected: Open Web Location dialog with the letter typed in the textbox.

This seems to only happen the first time the dialog is opened.  Similar things 
happen when pressing enter or trying to paste.

May be related to bug 35087, single-textfield dialogs shouldn't have to 
explicitl set focus to the textfield.
Same results for find dialog (Ctrl-F).

This bug is similar to bug 55015, which involves opening a new window as 
opposed to opening a dialog.
i think this is a dup of bug 41354...

*** This bug has been marked as a duplicate of 41354 ***
Status: NEW → RESOLVED
Closed: 24 years ago
Resolution: --- → DUPLICATE
I don't think it's a duplicate.  This is more of a timing issue.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
This is a fundamental problem in that we don't have event queues until a window
is up. We need a a new layer in event processing that cues up events until the
window is ready to process them.
Since Don has left, Vishy is taking his bugs in bulk, pending reassignment.
thanks,
	Vishy
Assignee: don → vishy
Status: REOPENED → NEW
nsbeta1?  
Keywords: nsbeta1
Unless someone else in event land wants to take this, I don't think it will get
fixed for the next round of releases.
-
Keywords: nsbeta1nsbeta1-
Bug 60150 might be related.
Reassigning to saari, but not expecting a fix for this release.
Assignee: vishy → saari
I wish I could fix it in this release, but no, that won't be happening.
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.0
also see this on linux -> all.

aaronl or akkana, would you be able to look and/or take this?
Keywords: helpwanted
OS: Windows 98 → All
Hardware: PC → All
This isn't a small bug fix, it is an design change. We need to revisit all of
our event queues to fix this! 
->future
Target Milestone: mozilla1.0 → Future
It's accel+shift+L to open this now.

Hmmm... WORKSFORME

Anyone else?
I still see this bug.
bryner/saari, could this be related to bug 108787?
No, not related to bug 108787, still seeing this on linux 2002011108.
If this requires a design change isn't it better to consider it before Mozilla
1.0 is out?

and also its duplicates like 
bug 55015



bug 41354 is marked as duplicate of this - it is marked as fixed and it looks
fixed for me with Build 2002050708, but this one is not.
This seems very hard to reproduce with the improvement in window opening times.
 Is anyone still experiencing this?  On what machine?
Status: ASSIGNED → RESOLVED
Closed: 24 years ago22 years ago
Resolution: --- → FIXED
New window open time is fast enough now that this is no longer an issue. In
addition, Accel+L now highlights the URL bar, which is the main way to
accomplish typing a new URL in with the keyboard.

If anyone still has a problem with this being closed, reopen.
Resolution: FIXED → WORKSFORME
mass-verifying WorksForMe bugs.

reopen only if this bug is still a problem with a *recent trunk build*.

mail search string for bugspam: AchilleaMillefolium
Status: RESOLVED → VERIFIED
I still see this with Phoenix's add-bookmark dialog.  Going to mark this as a
dup of bug 55015.
Status: VERIFIED → REOPENED
Resolution: WORKSFORME → ---
Summary: Open Web Location dialog doesn't accept keyboard input for a short time the first time it's opened → dialogs doesn't accept keyboard input for a short time the first time it's opened

*** This bug has been marked as a duplicate of 55015 ***
Status: REOPENED → RESOLVED
Closed: 22 years ago22 years ago
Resolution: --- → DUPLICATE
okay
Status: RESOLVED → VERIFIED
Component: Keyboard: Navigation → User events and focus handling
You need to log in before you can comment on or make changes to this bug.