Project comments not displaying

RESOLVED WONTFIX

Status

Websites Graveyard
www.drumbeat.org
--
major
RESOLVED WONTFIX
8 years ago
3 years ago

People

(Reporter: Jorge Couchet, Assigned: Ned Schwartz)

Tracking

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.2.4) Gecko/20100611 Firefox/3.6.4 (.NET CLR 3.5.30729)
Build Identifier: 

When I try to see the comments in the section 'comments" of my project (Every1Tutor), I'm able to see only two, but the system say me that they are 9 comments.

The problem ocurrs when I'm logged in or logged out.

Reproducible: Always

Steps to Reproduce:
1. Go to https://www.drumbeat.org/project/every1tutor-everyone-tutor/comments
2. Click the 'comments' section
3. You only will see two comments.
Actual Results:  
I cannot see all the comments left.

Expected Results:  
See all the comments (9).

Updated

8 years ago
Assignee: nobody → paulbooker

Comment 1

8 years ago
Thanks for the bug report Jorge.

@PaulO

The live preview on the views administration page shows the same view of 4 comments as displayed on the project page. Would you mind taking a look to see how many comments are actually in the database against the project node id = 33345 ?

I'll go a figure out how the project tab is constructed ..

Best,
Paul Booker
Appcoast

Comment 2

8 years ago
@PaulO

Would you mind sending me a recent snapshot of the database on production.

For later reference the code that renders the project tabs is located within our drumbeat_custom module .. 

/*
 * Content callback for project tabs block.
 */
function drumbeat_custom_block_content_project_tabs() {
  $nid = arg(1);
  if (is_numeric($nid) && ($node = node_load(array('nid' => $nid, 'type' => 'project')))) {
    $contributor = db_result(db_query(og_list_users_sql(1, 0, '', TRUE), $node->nid));

    $tabs = array(
      '' => t('project home'),
      'about' => t('about'),
      'blog' => t('blog'),
      'comments' => format_plural($node->comment_count, '1 comment', '@count comments'),
      'contributors' => format_plural($contributor, '1 contributor', '@count contributors')
    );

Best,
Paul Booker
Appcoast
(Reporter)

Comment 3

8 years ago
Hi Paul,

You are welcome!

Now the system tell me that I have 13 comments, but I only can access 4 of them.

Thanks for all!

Jorge

Updated

8 years ago
Severity: normal → major

Comment 4

8 years ago
@Jorge

This problem has since got worse the comment view is no longer displayed. 


@Ned

It looks as though there are some superfluous </ & < on views-view-fields--project-comments.tpl.php which may account for the HTML not being rendered on the page, would you mind taking a look into this?

PaulO

Would you mind taking a look to see how many comments are actually in the database against the project node id = 33345? 

I'll follow up on this bug later today / tomorrow morning

Best, 
Paul Booker
Appcoast

Comment 5

8 years ago
@ Ned: assigning to you
Assignee: paulbooker → ned
Summary: I have 9 comments, but I'm not able to see all → Project comments not displaying
This applies to the old version of drumbeat.org, no longer in production. Closing. Please create a new bug if the issue exists on the new site.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
Product: Websites → Websites Graveyard
You need to log in before you can comment on or make changes to this bug.