Next Unread doesn't work if multiple messages selected

RESOLVED WORKSFORME

Status

P3
normal
RESOLVED WORKSFORME
18 years ago
14 years ago

People

(Reporter: mpt, Unassigned)

Tracking

({qawanted})

Trunk
qawanted

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Build: 2000102008 trunk, Mac OS 9.0

To reproduce:
* Select more than one message in the thread pane.
* Choose Next Unread -- from the toolbar, the menu, or using the keyboard
  shortcut.

What should happen:
* Messenger advances to the next unread message.

What actually happens:
* Nothing.

Updated

18 years ago
QA Contact: esther → fenella

Updated

17 years ago
QA Contact: fenella → laurel

Comment 1

16 years ago
cvs build from sunday afternoon with no relevant patches to mailnews

in non threaded view with preview collapsed.

steps A:
1. i selected two messages (from one thread)
2. i selected go>next>unread thread

actual results A:
1. the thread was marked as read
2. the next message was selected

steps B:
1. i selected two messages sequentially from one thread
2. i selected go>next>unread message

actual results B:
1. the message after the second message in my selection was selected
2. the messages previously selected were deselected

steps C:
1. i selected a messages and then a later message from one thread
2. i selected go>next>unread message

actual results C:
1. the message after the latter message in my selection was selected
2. the messages previously selected were deselected

steps D:
1. i selected a message and the message before it from one thread
2. i selected go>next>unread message

actual results D:
1. the first message (ie the one after the most recently selected message) was
selected
2. the message that used to be the most recently selected was deselected

this happened even when the two messages were not adjacent.
Assignee: putterman → sspitzer
Keywords: qawanted

Comment 2

16 years ago
I also just noticed that this is marked as a Mac OS 8.5 bug - I am using Windows
2000, with Mozilla 1.2.1 (imported mail originally using Mozilla 1.0.1).  This
bug has been driving me nuts since September.

So, it is *not* a MAc only bug.

Comment 3

15 years ago
not a mac-classic-only bug. See comment 2
OS: Mac System 8.5 → All
Hardware: Macintosh → All
Product: Browser → Seamonkey

Comment 4

14 years ago
worksforme with linux trunk 2005032805
I get the same results as timeless, except for case D, where it now advances to
a message after the first-selected message.

case A seems strange (marking the thread as read), but seems to be intended behavior

Is anyone still seeing the originally reported bug (and if so, please provide
explicit steps)

Updated

14 years ago
Assignee: sspitzer → mail

Comment 5

14 years ago
resolving WORKSFORME
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.