Page save -=> saved File is compressed (Gzip)

VERIFIED DUPLICATE of bug 51852

Status

SeaMonkey
General
P3
normal
VERIFIED DUPLICATE of bug 51852
18 years ago
13 years ago

People

(Reporter: Matti, Assigned: Bill Law)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
You must have the latest nightly with a fix for bug49168.
Username : Mozilla
Password : Mozilla

Select File/Save as

Save the page (main.html) to your HDD.
Try to load the saved file from your HDD, the file is corrupt.

I saw this in the console while I save this page :
(This seems not be the problem)
************************************************************
* Call to xpconnect wrapped JSObject produced this error:  *
[Exception... "[Exception... "Illegal value"  code: "-2147024809" nsresult: "0x8
0070057 (NS_ERROR_ILLEGAL_VALUE)"  location: "chrome://global/content/downloadPr
ogress.js Line: 70"] [nsIObserver::Observe]"  nsresult: "0x8057001c (NS_ERROR_XP
C_JS_THREW_JS_OBJECT)"  location: "<unknown>"  data: no]
************************************************************
(Reporter)

Comment 1

18 years ago
Created attachment 17709 [details]
This is the saved file

Comment 2

18 years ago
adding mscott and law to cc.  Do one of you all know who should get this bug?
(Assignee)

Comment 3

18 years ago
I should probably get it.

What's happening is that the server is sending the data back using gzip
encoding.  When we save stuff, we turn auto-encoding off (so that gzip data
files don't end up being saved bigger than necessary).  In this case, that might
not be what you want.  If you run gzip -d against the saved file, you get what
you want.

The fix is to somehow enhance our smarts when it comes to choosing whether to
suppress this auto-encoding business.  Probably "save page as" should always
uncompress?  Or maybe it should be based on mime type?
Assignee: asa → law
(Assignee)

Updated

18 years ago
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Comment 4

17 years ago
*** Bug 64301 has been marked as a duplicate of this bug. ***
(Reporter)

Updated

17 years ago
Summary: Page save produce corrupt file → Page save -=> saved File is compressed (Gzip)
(Reporter)

Comment 5

17 years ago
changing summary
(Reporter)

Comment 6

17 years ago
dupe of 51852


*** This bug has been marked as a duplicate of 51852 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 7

17 years ago
That is my own bug, so I verify it
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.