Safe Mode's "Disable All Add-Ons" Has No Effect

VERIFIED FIXED in mozilla2.0b2

Status

()

Toolkit
Add-ons Manager
VERIFIED FIXED
8 years ago
7 years ago

People

(Reporter: Hjalte, Assigned: mano)

Tracking

({regression})

Trunk
mozilla2.0b2
regression
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -
in-litmus +

Firefox Tracking Flags

(blocking2.0 beta2+)

Details

(Whiteboard: [mozmill-test-needed])

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; Win64; x64; en-US; rv:1.9.3a6pre) Gecko/20100627 Minefield/3.7a6pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; Win64; x64; en-US; rv:1.9.3a6pre) Gecko/20100627 Minefield/3.7a6pre

When opening latest trunk in Safe Mode and checking "Disable all add-ons" and then clicking "Make changes and restart," all add-ons that were enabled prior to this remain enabled; in other words, this option has no effect on any of my add-ons and is broken.

Reproducible: Always

Comment 1

8 years ago
Regression window:

Works:
http://hg.mozilla.org/mozilla-central/rev/f4d925e68d55
Mozilla/5.0 (Windows; U; Windows NT 6.1; WOW64; en-US; rv:1.9.3a5pre) Gecko/20100506 Minefield/3.7a5pre ID:20100510144120

Fails:
http://hg.mozilla.org/mozilla-central/rev/5b027af3af29
Mozilla/5.0 (Windows; U; Windows NT 6.1; WOW64; en-US; rv:1.9.3a5pre) Gecko/20100510 Minefield/3.7a5pre ID:20100510161136

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=f4d925e68d55&tochange=5b027af3af29
Looking at that Range it would be better to check a mote narrow Range against the addonsmgr-Branch.
Component: General → Add-ons Manager
Keywords: regressionwindow-wanted
Product: Firefox → Toolkit
QA Contact: general → add-ons.manager
Version: unspecified → Trunk

Comment 3

8 years ago
(In reply to comment #2)
> Looking at that Range it would be better to check a mote narrow Range against
> the addonsmgr-Branch.

I think the addonsmgr-Branch has already been removed from server.
https://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/addonsmgr-win32/
There are not any builds.
This is unfortunate. I thought just producing new Builds had been stopped :-/.
It's not worth checking the add-ons manager branch - even it would still exist. I would say it's because we are using extensions.sqlite now and we probably still update extensions.rdf?

Dave, can we get this for beta 2?
Status: UNCONFIRMED → NEW
blocking2.0: --- → ?
Ever confirmed: true
Keywords: regressionwindow-wanted → regression
OS: Windows 7 → All
Yeah spotted this the other day and neglected to file a bug, this is just a problem with the safe mode UI not using the new API.
blocking2.0: ? → beta2+
Assignee: nobody → mano
Status: NEW → ASSIGNED
Comment on attachment 454930 [details] [diff] [review]
patch

Cool, thanks. I guess there is no way to automatically test this so we should flag it for a litmus test I think.

>diff -r 180af63d5358 browser/base/content/safeMode.js

>+  AddonManager.getAllAddons(function(aAddons) {
>+    aAddons.forEach(function(aAddon) {
>+      if (aAddon.type == "theme") {
>+        // Setting userDisabled to false on the default theme activates it,
>+        // disables all other themes and deactivates the applied persona, if
>+        // any.
>+        const DEFAULT_THEME_ID = "{972ce4c6-7e08-4474-a285-3208198ce6fd}";
>+        if (aAddon.id == DEFAULT_THEME_ID)
>+          aAddon.userDisabled = false;
>+      }
>+      else if (!aAddon.userDisabled)
>+        aAddon.userDisabled = true;

If userDisabled is already true then setting it to true is a no-op anyway so you could drop that if check if you wanted. Fine either way though.
Attachment #454930 - Flags: review?(dtownsend) → review+
Flags: in-testsuite-
Flags: in-litmus?
http://hg.mozilla.org/mozilla-central/rev/19cadd36d6dc
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.3b2
Blocks: 579773
No longer blocks: 579773
Blocks: 566194
Verified fixed with Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; en-US; rv:2.0b2pre) Gecko/20100718 Minefield/4.0b2pre
Status: RESOLVED → VERIFIED
Whiteboard: [mozmill-test-needed]

Comment 12

8 years ago
mmm the patch doesn't seem to fix it. I'm using about a 3hour old build:
http://hg.mozilla.org/mozilla-central/rev/8ab6bd1f88aa
(In reply to comment #12)
> mmm the patch doesn't seem to fix it. I'm using about a 3hour old build:
> http://hg.mozilla.org/mozilla-central/rev/8ab6bd1f88aa

See bug 566194. That's the only left issue. If extensions are still enabled for you (beside the add-ons manager ui) please file a new bug.

Comment 14

8 years ago
(In reply to comment #13)
> (In reply to comment #12)
> > mmm the patch doesn't seem to fix it. I'm using about a 3hour old build:
> > http://hg.mozilla.org/mozilla-central/rev/8ab6bd1f88aa
> 
> See bug 566194. That's the only left issue. If extensions are still enabled for
> you (beside the add-ons manager ui) please file a new bug.

I don't quite get what that bug says.
All I know is I set safe mode to disable all addons. Addons are still enabled. Isn't that what this bug's for?
So please give us more information. On which platform are you working? Don't have add-ons the '(Disabled)' part after the version number? Are menu entries or toolbar buttons still shown? Can you attach a screenshot?

Comment 16

8 years ago
(In reply to comment #15)
> So please give us more information. On which platform are you working? Don't
> have add-ons the '(Disabled)' part after the version number? Are menu entries
> or toolbar buttons still shown? Can you attach a screenshot?

A screenshot wouldn't help. I'm on Win7 32bit. Yes menu entries and toolbar buttons are still shown.

And I think we're talking about different things. What I mean is when you check [disable all addons] and click on "make changes and restart" the addons aren't disabled. But when you just enter safemode and click on "continue in safemode", the addons are successfully disabled.
(In reply to comment #16)
> And I think we're talking about different things. What I mean is when you check
> [disable all addons] and click on "make changes and restart" the addons aren't
> disabled. But when you just enter safemode and click on "continue in safemode",
> the addons are successfully disabled.

For me both Ways of Disabling Addons (Continue in Safe Mode & Disable all add-ons + Make Changes and Restart) is WFM using a fresh Profile + global installed and profile-specific Addons.

As Henrik mentioned, if you can reproduce an Issue please file a new Report with exact Steps how you reproduced it.
Depends on: 600068
Flags: in-litmus? → in-litmus?(vlad.maniac)
The Litmus from bug 600068 covers that:
https://litmus.mozilla.org/show_test.cgi?id=15171
Flags: in-litmus?(vlad.maniac) → in-litmus+
You need to log in before you can comment on or make changes to this bug.