Compressed window causes Firefox button to overlap caption buttons

RESOLVED WONTFIX

Status

()

Firefox
Theme
RESOLVED WONTFIX
8 years ago
5 years ago

People

(Reporter: jimm, Unassigned)

Tracking

Trunk
x86
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
Created attachment 454460 [details]
screenshot

We should probably set a min window width to prevent this, or hide the fx button when the width decreases below the width of the captions and button.

Comment 1

8 years ago
The Windows UX guidelines mentioned somewhere that if a window becomes too small, the entire chrome should disappear. This happens on the MS Office programs.

Comment 2

7 years ago
(In reply to comment #1)
> The Windows UX guidelines mentioned somewhere that if a window becomes too
> small, the entire chrome should disappear. This happens on the MS Office
> programs.

In Windows 7, explorer has a min window width, and MS Word 2010's icon slightly overlaps the minimize button.

http://img707.imageshack.us/img707/1237/clipboard01jur.png

Comment 3

7 years ago
This issue doesn't belongs to commpressed windows only.
It appears also sometimes in the normal workflow without resizing the window.
The personas theme overlaps then the caption buttons. There is no way to resolve this behavior except to close the window it belongs.

There must be a case where the window painting function first draw the window frame and and then the personas theme, so the theme overlaps the buttons.

If I switch between the firefox windows the issued window is first correctly drawn. But if I move the mouse in this window the personas theme overlaps the buttons again.

Tested with:
Firefox 4.0b5

Comment 4

7 years ago
Created attachment 475056 [details]
Firefox theme overlaps caption buttons

https://bugzilla.mozilla.org/show_bug.cgi?id=575200#c3
(Reporter)

Comment 5

7 years ago
(In reply to comment #4)
> Created attachment 475056 [details]
> Firefox theme overlaps caption buttons
> 
> https://bugzilla.mozilla.org/show_bug.cgi?id=575200#c3

This looks like a different bug. Do you run in aero basic, or has your aero glass been shut down on the window? (The fact that you're messing with java in your two tabs seems suspect.) If you're experiencing aero glass shutdown (bug 545892) and have a way to reproduce that, please post it in that bug.

Comment 6

7 years ago
the minimum window size bug is bug 548777

Updated

7 years ago
Depends on: 548777
Blocks: 613782
(Reporter)

Comment 7

7 years ago
This is due to the flex spacer in the middle having a minimum size. Which from my understanding shouldn't happen but something is clearly forcing it stop flexing at a certain point.
(Reporter)

Updated

7 years ago
No longer blocks: 613782
Duplicate of this bug: 613782
The Firefox button is going to be removed in bug 863753.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.