Welcome page shows Shredder instead of Thunderbird

RESOLVED FIXED

Status

www.mozilla.org
Thunderbird
RESOLVED FIXED
8 years ago
5 years ago

People

(Reporter: jhorak, Assigned: gozer)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
There is a problem with Thunderbird welcome page in branded builds in Fedora. Instead of showing:

Welcome to Thunderbird!
Mozilla’s Thunderbird is all yours - your language, your add-ons, your email...

it shows:

Welcome to Shredder!
Congratulations! You've downloaded or compiled Shredder. This means that you've volunteered to...

This is due to different build id between binaries from mozilla and binaries we build on Fedora. 

Fedora's build welcome page URL: http://live.mozillamessaging.com/thunderbird/firstrun?locale=en-US&version=3.1&os=Linux&buildid=20100622085750

Mozilla's build welcome page URL: http://live.mozillamessaging.com/thunderbird/firstrun?locale=en-US&version=3.1&os=Linux&buildid=20100608021630

Reproduce steps:

To obtain welcome page url use in error console following command and open returned URL:
Components.classes["@mozilla.org/toolkit/URLFormatterService;1"].getService(Components.interfaces.nsIURLFormatter).formatURLPref("mailnews.start_page.welcome_url");

Comment 1

8 years ago
Same on OpenSolaris:
http://live.mozillamessaging.com/thunderbird/start?locale=en-US&version=3.1&os=SunOS&buildid=20100610153108
We need to add that to our check list. Canadians are on vacation today, so don't expect a fix today but probably tomorrow.
Component: Help Documentation → www.mozillamessaging.com
Product: Thunderbird → Websites
QA Contact: help-documentation → www-mozillamessaging-com
Version: 3.1 → other
Assignee: nobody → gozer
(Assignee)

Comment 3

8 years ago
This was because the redirects were still triggered by build id from the RC period. Now fixed, all redirects with version=3.1 (except for rc1 buildids) should correctly redirect.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.