The "Exit" dialog ignores Windows' automatic cursor placement

RESOLVED WORKSFORME

Status

()

Core
XP Toolkit/Widgets: XUL
--
trivial
RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: der_tuxman, Unassigned)

Tracking

({regression})

1.9.1 Branch
x86
Windows 7
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; de; rv:1.9.2.6) Gecko/20100627 Firefox/3.6.4 (tete009 SSE2 PGO)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; de; rv:1.9.2.6) Gecko/20100627 Firefox/3.6.4 (tete009 SSE2 PGO)

When I enable Windows' "automatically place the mouse cursor on default dialog buttons" functionality, recent SeaMonkey builds ignore it when displaying the Exit confirmation dialog, the cursor is not placed on the default button.

(Not sure if this is better put into "OS integration".)

Reproducible: Always

Comment 1

8 years ago
Is this report against SeaMonkey or Firefox? Your user agent says Firefox/3.6.4.
This is probably broken by design since gecko paints it's own buttons and doesn't use the OS button widget.

Moving to some random component in core where the peers there can WONTFIX or whatever.
Component: UI Design → XP Toolkit/Widgets: XUL
Product: SeaMonkey → Core
QA Contact: ui-design → xptoolkit.xul

Comment 2

8 years ago
No, we do support this feature, and it works in a random build from around March. 
It doesn't work in a build from at least April 11. I didn't narrow it down further.
Keywords: regression, regressionwindow-wanted
(Reporter)

Comment 3

8 years ago
(In reply to comment #1)
> Is this report against SeaMonkey or Firefox? Your user agent says
> Firefox/3.6.4.

It is against SeaMonkey, Firefox works.
WFM using Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101214 Firefox/4.0b8pre ID:20101214030322

So presumably this should be moved back to the SeaMonkey product, if it still doesn't work in the latest version of SeaMonkey?

Comment 5

7 years ago
OK how do I test this. I mean the Windows 7 control panel is a maze where I can't find anything.
Win 7 Control Panel -> Mouse -> Pointer Options Tab -> Tick "Automatically move pointer to default button in dialog box"

Comment 7

7 years ago
WFM:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101214 SeaMonkey/2.1b2pre

Still broken on:
Mozilla/5.0 (Windows; U; Windows NT 6.1; rv:1.9.1.17pre) Gecko/20101211 Lightning/1.0b2pre SeaMonkey/2.0.12pre

So since the 1.9.1 branch is in maintenance mode (security and stability fixes only) I guess this is WONTFIX?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: WONTFIX?
Version: unspecified → 1.9.1 Branch
(Reporter)

Comment 8

7 years ago
I guess it still is in 1.9.2?

Comment 9

7 years ago
SeaMonkey 2.0.x is built on the Gecko 1.9.1 branch.
SeaMonkey 2.1b2pre is built on the Gecko 2.0 branch.
There is no SeaMonkey version released against Gecko 1.9.2.

Since comment 3 says that the problem doesn't exist in Firefox 3.6.4 (Gecko 1.9.2) I assume that it is WFM on applications built with Gecko 1.9.2.
Per comment 9, marking as WFM using supported versions of SeaMonkey/Gecko.
Please reopen if it still occurs using the latest SeaMonkey trunk build - thanks!
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Keywords: regressionwindow-wanted
Resolution: --- → WORKSFORME
Whiteboard: WONTFIX?
You need to log in before you can comment on or make changes to this bug.