NS_ERROR_UNEXPECTED in AccountWizard.js: Mozilla crashes after Account Wizard Finish button clicked.

VERIFIED WORKSFORME

Status

P3
critical
VERIFIED WORKSFORME
18 years ago
14 years ago

People

(Reporter: edcjones, Assigned: sspitzer)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; Linux 2.2.17 i586)
BuildID:    2000101015

At the end of installing Mozilla, I started mozilla. Then I clicked on the mail
icon. The Mail and Account Wizard screens appeared. After answering the
questions, I clicked Finish. Mozilla crashed.

Reproducible: Always
Steps to Reproduce:
1    As root:
     cd /usr/local
     rm -rf /root/.mozilla
     rm -rf package
     tar -xzf mozilla-i686-pc-linux-gnu-M18.tar.gz
     cd package
     ./mozilla &> mess
     Mozilla appears
2    Click mail icon
     MailNews screen appears
     Account Wizard appears, new Account Setup screen
3    "ISP or email provider" is default, click Next, Identity screen appears
4    Typed in name and emailaddress
     Click Next, Server Information screen appears
5    Typed in POP and SMTP servers
     Click Next, User Name screen appears
6    Click Next, Account Name screen appears
7    Click Next, Congratulations! screen appears
8    Click Finish
9    Mozilla crashes.

Actual Results:
1    As root:
     cd /usr/local
     rm -rf /root/.mozilla
     rm -rf package
     tar -xzf mozilla-i686-pc-linux-gnu-M18.tar.gz
     cd package
     ./mozilla &> mess
     Mozilla appears
./run-mozilla.sh ./mozilla-bin
MOZILLA_FIVE_HOME=.
  LD_LIBRARY_PATH=.
     LIBRARY_PATH=.:./components
       SHLIB_PATH=.
          LIBPATH=.
       ADDON_PATH=.
      MOZ_PROGRAM=./mozilla-bin
      MOZ_TOOLKIT=
        moz_debug=0
     moz_debugger=
RegSelf Shift_JIS to Unicode converter complete
RegSelf EUC-JP to Unicode converter complete
RegSelf ISO-2022-JP to Unicode converter complete
RegSelf Unicode to Shift_JIS converter complete
RegSelf Unicode to EUC-JP converter complete
RegSelf Unicode to ISO-2022-JP converter complete
RegSelf Unicode to jis_0201 converter complete
RegSelf Unicode to jis_0208-1983 converter complete
RegSelf Unicode to jis_0212-1990 converter complete
RegSelf Unicode to Big5 converter complete
RegSelf Unicode to x-x-big5 converter complete
RegSelf Big5 to Unicode converter complete
ProfileManager : CreateNewProfile
Profile Name: default
Profile Dir: /root/.mozilla
Setting content window
*** Pulling out the charset
Loading page specified via openDialog
in SetSecurityButton
Document http://www.mozilla.org/mozorg.html loaded successfully

2    Click mail icon
     MailNews screen appears
     Account Wizard appears, new Account Setup screen
we don't handle eBorderStyle_close yet... please fix me
attempt to UpgradePrefs.  If that fails, open the account wizard.
start message pane with: http://www.mozilla.org/mailnews/start.html
In SortColumn
SetupCommandUpdateHandlers
in SetSecurityButton
we don't handle eBorderStyle_close yet... please fix me
Updating wizard map..
got a request
** acctype onload
Calling custom onInit()

3    "ISP or email provider" is default, click Next, Identity screen appears
wizardAdapter: GetFields()
    for field <radio>
    returning mailaccount and true value=ISP or email provider
    for field <radio>
    returning $89f78d0 and false
value=rdf:http://home.netscape.com/NC-rdf#wizardLongName
    for field <radio>
    returning newsaccount and false value=Newsgroup account
got a request
OnUnload!
Updating wizard map..
Accounttype is mail: true
initializing ISP data for mailaccount
AccountWizard.prefillAccountForIsp(mailaccount)
PrefillAccountForISP: filling with null
null account data! clearing..
This is an accountdata
Updating wizard map..
Accounttype is mail: true
Calling custom onInit()

4    Typed in name and emailaddress
     Click Next, Server Information screen appears
Updating wizard map..
Accounttype is mail: true
wizardAdapter: GetFields()
    for field <textfield>
    returning fullName and Edward C. Jones value=Edward C. Jones
    for field <textfield>
    returning email and xxxx@erols.com value=xxxx@erols.com
got a request
Calling custom onInit()

5    Typed in POP and SMTP servers
     Click Next, User Name screen appears
wizardAdapter: GetFields()
    for field <menulist>
    returning servertype and pop3 value=POP Mail Server
    for field <textfield>
    returning hostname and pop.erols.com value=pop.erols.com
    for field <textfield>
    returning smtphostname and smtp.erols.com value=smtp.erols.com
got a request
Calling custom onInit()
type = pop3

6    Click Next, Account Name screen appears
AccountExists(xxxx,pop.erols.com,pop3)
AccountExists() failed: [Exception... "Component returned failure code:
0x8000ffff (NS_ERROR_UNEXPECTED) [nsIMsgAccountManager.FindServer]"  nsresult:
"0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame ::
chrome://messenger/content/AccountWizard.js :: AccountExists :: line 533"  data:
no]
wizardAdapter: GetFields()
    for field <textfield>
    returning username and xxxx value=xxxx
got a request
Calling custom onInit()

7    Click Next, Congratulations! screen appears
wizardAdapter: GetFields()
    for field <textfield>
    returning prettyName and xxxx@erols.com value=xxxx@erols.com
got a request
Calling custom onInit()

8    Click Finish
WSM.PageData[accounttype][mailaccount][id] : mailaccount;
WSM.PageData[accounttype][mailaccount][value] : true;
WSM.PageData[accounttype][$89f78d0][id] : $89f78d0;
WSM.PageData[accounttype][$89f78d0][value] : false;
WSM.PageData[accounttype][newsaccount][id] : newsaccount;
WSM.PageData[accounttype][newsaccount][value] : false;
WSM.PageData[server][servertype][id] : servertype;
WSM.PageData[server][servertype][value] : pop3;
WSM.PageData[server][hostname][id] : hostname;
WSM.PageData[server][hostname][value] : pop.erols.com;
WSM.PageData[server][smtphostname][id] : smtphostname;
WSM.PageData[server][smtphostname][value] : smtp.erols.com;
WSM.PageData[login][username][id] : username;
WSM.PageData[login][username][value] : xxxx;
WSM.PageData[accname][prettyName][id] : prettyName;
WSM.PageData[accname][prettyName][value] : xxxx@erols.com;
WSM.PageData[identity][fullName][id] : fullName;
WSM.PageData[identity][fullName][value] : Edward C. Jones;
WSM.PageData[identity][email][id] : email;
WSM.PageData[identity][email][value] : xxxx@erols.com;
Setting identity for xxxx@erols.com
pageData.server = [object Object]
pageData.server.smtphostname.value = [object Object]
am.createIncomingServer(xxxx,pop.erols.com,pop3)
am.createIdentity()
am.createAccount()
srcServer.ServerType-pop3 = undefined
Copying smtpServer ([xpconnect wrapped nsISmtpServer]) to accountData
Looking for Local Folders.....
finding folders on server = pop.erols.com
fccFolder = mailbox://xxxx@pop.erols.com/Sent
draftFolder = mailbox://xxxx@pop.erols.com/Drafts
stationeryFolder = mailbox://xxxx@pop.erols.com/Templates
in showthreads

9    Mozilla crashes.


Expected Results:  Remove the account Wizard screen, leaving the main and mail
screens up.
taking from alecf.

I'll investigate.
Assignee: alecf → sspitzer

Comment 2

18 years ago
I am unable to reproduce this crash with 102708 mozilla trunk build or 10/27
mozilla branch build on RedHat6.2.  

Comment 3

18 years ago
I am unable to reproduce this using RedHat 6.2 and Mozilla build (10-31) and
Netscape Commercial build (10-31).

Comment 4

18 years ago
The problem here for you is at step 6. accountExists(name, hostname, type) calls
nsMsgAccountManager::FindServer(name, hostname, type) which returns
NS_ERROR_UNEXPECTED if serverInfo.server is undefined. It is an exception.
See chrome://messenger/content/AccountManager.js line 531  and
http://lxr.mozilla.org/seamonkey/source/mailnews/base/src/nsMsgAccountManager.cpp#1502
Fabian.
Btw this worksforme build 2000111004 mtrunk win32

Comment 5

18 years ago
Marking as WFM as per comments. Reopen if this is still a problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 6

18 years ago
Verified Worksforme.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.