Include this Server while getting new mail should be moved

RESOLVED INVALID

Status

Thunderbird
Account Manager
--
minor
RESOLVED INVALID
8 years ago
5 years ago

People

(Reporter: Jim, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6 (.NET CLR 2.0.50727)
Build Identifier: Build identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.2.4) Gecko/20100608 Thunderbird/3.1

The "Include this Server while getting new mail" should not be buried on the Adavance button on the Account Settings | Server page. This option should be placed on the same screen and grouped with the rest of the settings pertaining to the Checking for mail for an account on startup of Thunderbird. Either that or automatically enable the "Include this Server while getting new mail" if the "Check for new messages on startup" is enabled.

Reproducible: Always




If one enables "Check for new messages on startup" for account do you really need "Include this Server while getting new mail" option? If so at least have the "Include this Server while getting new mail" out in the open so that TB will in fact check this server when the application is started like the user wanted to rather than several minutes later. This way the end user ensures that they have all their current email.

Comment 1

7 years ago
I support this request. Today I configured Thunderbird and I didn't find the reason why Thunderbird did not fetch all accounts in first place. I spent about 30 Minutes about this issue and I found the solution only after further searching the internet. I think other people may be annoyed by this issue too.
Jim & Tobias, thanks for reporting & sorry for the delayed response.

I think this is based on misunderstandings and wrong conclusions from found behaviour.

This bug is about a preference found here:
Tools > Account Settings > YourAccount > Server Settings > Message Storage > Advanced

That's this dialogue:

[Advanced Account Settings]
For Account "YourAccount"
When downloading pop mail for this server, use the following folder for new mail: 

a) (o) Inbox for this server's account
b) ( ) Global Inbox (Local Folders Account)
c) ( ) Inbox for different Account [Account Selector]

x) [ ] Include this server when getting new mail

You can only enable x) for cases of b) or c), never for a) which I believe is default. Note that b) is a different animal from what we have as "Unified Inbox".

So I think this old pref is about including a pop server Pop2 for downloading when you download messages for pop server Pop1 or the global inbox, i.e. it's about combining several pop accounts to act like one big account (e.g. when you press F5 on Pop1, Pop2 will also be polled and Pop2 messages are downloaded to Pop1 inbox). For that purpose, I believe the pref is in the right place UI-wise.

Downloading new messages at startup has nothing much to do with that.
I recall having seen some old bugs that "Get new messages at startup" doesn't work under certain conditions, which is probably what reporter saw, and then wrongly concluded that the above-mentioned advanced preference is at fault.

The default usecase is having separate accounts each with their own inbox, which can be combined into a virtual "unified inbox" (which is different from physical combination of global inbox in above dialogue).

For the default usecase, there's Bug 563334 for implementing an "include this account when getting all messages" pref, which is currently being implemented in related bug 281417. That's also different from the include pref mentioned in this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.