LoadPlugin: failed to initialize shared library /usr/lib/jvm/java-6-openjdk/jre/lib/i386/IcedTeaPlugin.so

RESOLVED WORKSFORME

Status

Thunderbird
General
RESOLVED WORKSFORME
7 years ago
6 years ago

People

(Reporter: Daniel Hahler, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2012-02-23])

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.9.2.3) Gecko/20100423 Ubuntu/10.04 (lucid) Firefox/3.6.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.3a6pre) Gecko/20100628 Shredder/3.2a1pre

I am getting the following error on the console, when running Thunderbird:

LoadPlugin: failed to initialize shared library /usr/lib/jvm/java-6-openjdk/jre/lib/i386/IcedTeaPlugin.so [libxul.so: cannot open shared object file: No such file or directory]

It appears during startup, and whenever I select a message (newsgroup or email), but then twice in a row.

Reproducible: Always

Actual Results:  
There shouldn't be any error.


I am using Ubuntu Lucid, but the vanilla 3.1 release.

I've just tested it using the nightly build (see identifier).

The file itself exists:
% ls -l /usr/lib/jvm/java-6-openjdk/jre/lib/i386/IcedTeaPlugin.so
-rw-r--r-- 1 root root 190904 2010-06-26 11:14 /usr/lib/jvm/java-6-openjdk/jre/lib/i386/IcedTeaPlugin.so
What does a file /usr/lib/jvm/java-6-openjdk/jre/lib/i386/IcedTeaPlugin.so says ?

Do you get the same kind of errors in Firefox (4.0b1 for instance) ?
(Reporter)

Comment 2

7 years ago
This is apparently related to OpenJDK (6b18-1.8-0ubuntu2 on Ubuntu).

In the meantime, I've switched to using Sun's "original" Java, and the error does not appear.

I will try reproducing it later (by installing OpenJDK again and making it the default java), and will provide the output of "file" then, too.
(Reporter)

Comment 3

7 years ago
Ok, having installed icedtea6-plugin and default-jdk (OpenJDK) again, it displays those errors again.

"file" says:
/usr/lib/jvm/java-6-openjdk/jre/lib/i386/IcedTeaPlugin.so: ELF 32-bit LSB shared object, Intel 80386, version 1 (SYSV), dynamically linked, stripped
(Reporter)

Comment 4

7 years ago
Firefox (Minefield, 4.0b2pre) does not complain like that, when it uses Java, e.g. on http://www.java.com/en/download/help/testvm.xml, it dumps the following to console, but no errors:
  java version "1.6.0_18"
  OpenJDK Runtime Environment (IcedTea6 1.8) (6b18-1.8-0ubuntu2)
  OpenJDK Server VM (build 14.0-b16, mixed mode)
Mark any idea what might be going wrong here ?

Comment 6

7 years ago
I was getting the same error and everything was in place, just like the OP. But this is on Debian Testing instead. 

After I did the following that error went away on that terminal:

$ export LD_LIBRARY_PATH=/usr/lib/xulrunner-1.9.1/

After a logout and login, that error message does not come up any more; on any terminals used to start Thunderbird. Without having to export again.

Not sure is this affects anything else, but it's working fine here so far.

Comment 7

6 years ago
Reporter do you still see this problem when using recent version of
Thunderbird?
Whiteboard: [closeme 2012-02-23]
RESOLVED INCOMPLETE due to lack of response to the previous comment. If you feel this change was made in error, please respond to this bug with your reasons why.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 9

6 years ago
Closing as WORKSFORME, because it appears to be fixed (since a while already probably).
Thanks!
Resolution: INCOMPLETE → WORKSFORME
You need to log in before you can comment on or make changes to this bug.