Search fails to find the mobile add-on- "Event Spy" when advanced option,app_version is set to 0.1

VERIFIED FIXED in 5.11.4

Status

addons.mozilla.org Graveyard
Public Pages
--
major
VERIFIED FIXED
8 years ago
2 years ago

People

(Reporter: krupa, Assigned: davedash)

Tracking

Details

(Whiteboard: [z][r?jbalogh], URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Created attachment 454607 [details]
screenshot

user agent:Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6

steps to reproduce:
1.In mobile AMO homepage,search for "Near me" with app version=0.7

expected behavior:
Since the add-on is supported from 1.0b6pre - 1.1.*,search should list this add-on in the results(https://next.addons.mozilla.org/en-US/mobile/addon/53633/)

actual behavior:
when searching with version=0.7,search fails to find the add-on (https://next.addons.mozilla.org/en-US/mobile/search/?q=Near+me&cat=all&lver=0.7&pid=1&sort=&pp=20&lup=&advanced=on)
(Reporter)

Comment 1

8 years ago
note to self:when sleepy,drink coffee!
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

8 years ago
STR:
1.Search for add-on "Event spy" with version=0.1
2.Go to the add-on detail page and check the supported range.(https://next.addons.mozilla.org/en-US/mobile/addon/1100/)

expected behavior:
Since this add-on is supported from Mobile 0.1 - 2.0a1pre,search should find the add-on

actual behavior:
Search fails to find the add-on https://next.addons.mozilla.org/en-US/mobile/search/?q=event+spy&cat=all&lver=0.1&pid=1&sort=&pp=20&lup=&advanced=on
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Summary: Searching for mobile add-on-"Near me" with version =0.7,does not find results → Search fails to find the mobile add-on- "Event Spy" when advanced option,app_version is set to 0.1
Hardcoding to version 0.11 or 0.2 in the URL works.  Is this a a < vs <= error?

-> davedash, if this will take time, let's kick to 5.11.4
Assignee: nobody → dd
Won't have time for these today, but will start looking for 5.11.4.
Target Milestone: 5.11.3 → 5.11.4
r? http://github.com/davedash/zamboni/compare/master...mobile-search-575378
Status: REOPENED → ASSIGNED
Whiteboard: [z] → [z][r?jbalogh]
http://github.com/jbalogh/zamboni/commits/2baa6ef
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED
(Reporter)

Comment 7

8 years ago
verified at https://preview.addons.mozilla.org/en-US/mobile/search/?q=event+spy&cat=all&lver=0.1&pid=1&sort=&pp=20&lup=&advanced=on
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.