bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Empty notification popup upon focus to unavailable mailbox folder

VERIFIED FIXED

Status

Thunderbird
Mail Window Front End
--
major
VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: Thommie Rother, Assigned: standard8)

Tracking

Firefox Tracking Flags

(blocking-thunderbird3.1 .1+, thunderbird3.1 .1-fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de; rv:1.9.2.3) Gecko/20100401 SUSE/3.6.3-1.2 Firefox/3.6.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; de; rv:1.9.2.4) Gecko/20100608 SUSE/3.1.0 Thunderbird/3.1

TB shows an empty notification popup after a click to an IMAP folder which is currently not available. 

Setup: two accounts to the same IMAP server, one for connection from the internet (Server name *.netzwissen.de), the other directs to the same server, but only for a connection from the the local network (Servername *netzwissen.local). If you click on one of the folders of the currently unavailable server, you get a notification popup. The notification itself is ok, but this notification is empty. See attachment. Behaviour is new since TB 3.1, migration was done from 3.0, so there was no change of the configuration (prefs.js).

Reproducible: Always

Steps to Reproduce:
1. click on unavailable imap folder (tb in online mode!)

Actual Results:  
empty notification popup

Expected Results:  
notification contains text
(Reporter)

Comment 1

8 years ago
Created attachment 454612 [details]
empty notificaton popup
(Reporter)

Updated

8 years ago
Version: unspecified → 3.1
This was caused by the incorrect back out of bug 561427 by http://hg.mozilla.org/releases/comm-1.9.2/rev/3b34e3d4519c
Assignee: nobody → bugzilla
Status: UNCONFIRMED → NEW
blocking-thunderbird3.1: --- → .1+
Ever confirmed: true
I have re-landed the backed-out patch for 1.9.2 nightly builds:

http://hg.mozilla.org/releases/comm-1.9.2/rev/524f27904bd0

We still need to ensure that we get this in for the 3.1.1 release, hence leaving open for now.
Checked into rebranch as well for 3.1.1 build 2:

http://hg.mozilla.org/releases/comm-1.9.2/rev/2b7c76dd6f39
Status: NEW → RESOLVED
Last Resolved: 8 years ago
status-thunderbird3.1: --- → .1-fixed
Resolution: --- → FIXED
(Reporter)

Comment 5

8 years ago
solved, may be closed
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.