Deploy Crashplan Server for Toronto Office

RESOLVED FIXED

Status

RESOLVED FIXED
9 years ago
4 years ago

People

(Reporter: Ehsan, Assigned: sean)

Tracking

Details

(Reporter)

Description

9 years ago
I have not been able to access caadm01 after I've updated my LDAP password.  Logging in with my POSIX user name (eakhgari) and new password doesn't work.  I can't use my old password, unfortunately, since I don't know what it was!
Assignee: nobody → server-ops
Component: Release Engineering → Server Operations
QA Contact: release → mrz
Ehsan, I checked the ldap database for caadm01 and it looks like it is synced up with the master properly. Are you able to authenticate to other services, or is caadm01 the only server not accepting your password? If that is the case, I'm wondering if there are any special characters that the appletalk server doesn't recognize. I'm just seeing generic authentication failures in the logs.
(Reporter)

Comment 2

9 years ago
My password is alphanumeric, so I guess special characters should not be an issue.  I can authenticate to the intranet using my LDAP info, for example.  What other services should I try?
Ehsan, if it works for intranet, then it should work there as well. There were some unrelated fixes to the LDAP system this past week, which should all be done now. Could you try again? If it still doesn't work, I can only suggest to try resetting your password again. The appletalk system on that server must have some problem with your password, although I don't think it is length related. I had no trouble authenticating with a 20+ character password.
10 days later, it's working I hope?
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Reporter)

Comment 5

9 years ago
I'll test it when I come to the office later today.  I was on vacation, and then at the Summit, hence the delay.  Sorry about that.
(Reporter)

Comment 6

9 years ago
My old password still didn't work.  I reset my LDAP password and tried again, and it still doesn't work.  :(
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Access to the existing server is quite unreliable in my experience. Using Finder to access it using smb:// fails consistently ("invalid username/password") no matter what username/password I use. Accessing over afp:// works if I use my POSIX username ("gavin") and my LDAP password, but I can only actually mount the "Toronto Public Fileshare" share - selecting my private "gavin" share results in Finder just sitting at a "Connecting..." screen until it times out.

I hear we're getting a new crashplan server soon anyways, so I would be fine with just having the data in my directory there securely wiped.
I think the overall problem is likely an outdated implementation of netatalk. I think it will be a wontfix situation ince we are currently building out the new CrashPlan server, let's tweak this bug to track that deployment instead.

As for the status: The server is built with an OS, I'm currently installing the CrashPlan software.
Assignee: server-ops → jdow
Summary: Cannot access caadm01 after updating my LDAP password → Deploy Crashplan Server for Toronto Office
The server is built and the software is installed. Over to Sean for configuration.
Assignee: jdow → sean
(Assignee)

Comment 10

9 years ago
This shipped out yesterday, but will still need some configuration when it gets there.
Status: REOPENED → ASSIGNED
Whiteboard: Shipped
We just received a big iX systems box, which I'm guessing is this server. Do you want me to set it up and hook it up to the network?
Looks like this arrived, but cc'ing Hilary for good measure.
Gavin, if you are able to rack it and plug it in, we could probably configure it from here. Only problem is, I didn't note down the MAC addresses of its NICs, so perhaps ping one of us on IRC before plugging in the patch cables, so we can sniff out the MACs from dhcp logs. From there we can then assign a static IP address, put it into DNS and Nagios, etc.

You'll need three patch cables (and three free switch ports) for it.
I heard a rumor that Sean's coming for a visit, so I guess I should probably leave the fun to him? :)
(In reply to comment #14)
> I heard a rumor that Sean's coming for a visit, so I guess I should probably
> leave the fun to him? :)

Anyone who suggests that Gavin is to set up the server will be the first against the wall the next time I'm in Mountain View.
(Assignee)

Comment 16

8 years ago
This is up and running.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago8 years ago
Resolution: --- → FIXED
Whiteboard: Shipped
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.