Keyword.Url Not Working (Default Search Engine Search)

RESOLVED INVALID

Status

()

P5
critical
RESOLVED INVALID
8 years ago
a year ago

People

(Reporter: justintjacob, Unassigned)

Tracking

3.6 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3

after upgrading to  Firefox 3.6.6 Default Search Not Working ,I check about:config
Keyword.url ,its set to google,but if we type any word in address bar its showing host not found error,so i again installed Version 3.6.3,in that version its working,Version 3.6.5 Also same Problem

Reproducible: Always

Actual Results:  
host not Found Error
(Reporter)

Updated

8 years ago
Severity: normal → critical
Priority: -- → P5
Version: unspecified → 3.6 Branch
Component: Build Config → Location Bar
QA Contact: build.config → location.bar
There was no 3.6.5, only 3.6.6. Is keyword.enabled set to true?
(Reporter)

Comment 2

8 years ago
Yes ,Its True

Comment 3

8 years ago
What did you search? If you searched for anything including a colon or period then this would cause the browser to think that you are typing a URL instead of a search query.

Comment 4

8 years ago
Confirmed here. Reported last week but that bug was closed by me (by accident).

Comment 5

8 years ago
Also happens in the trunk builds (which was what I was using when I reported the bug originally).

Updated

8 years ago
Duplicate of this bug: 587453

Comment 7

8 years ago
I thought I was the first to spot this issue. Turns out I wasn't, you were. Good hunting.

Also, does anyone know what changelog caused this? (because I'd be useless. :P)
Is this till an issue ?

Comment 9

6 years ago
I think so. Firefox still hangs sometimes when searching for words in the address bar, mainly on 1 word queries.
bug 595148 is about the hang

Comment 11

5 years ago
Mozilla/5.0 (Windows NT 6.1; rv:26.0) Gecko/20100101 Firefox/26.0

WFM with latest Nightly (Build ID: 20130811030225).

Reporter, do you still see this issue?
Regarding the hang, could you please take a look at bug 595148?
Flags: needinfo?(justintjacob)

Comment 12

5 years ago
keyword.URL and keyword.enabled are removed from Firefox in v23. I think this bug is INVALID now.

Comment 13

5 years ago
I just upgraded to 23.0 (20130730113002) today and double checked that Firefox is fully updated.

The location bar always takes me to google no matter how many words I type (1 to many).  I have triple checked that Keyword.Url is set to the correct path to use a different search engine but my custom path is ignored.

I did not experience this bug in 22.0 (20130618035212).

Please let me know if I can provide any more additional information to help solve this issue.

Thank you.
Firefox 23 doesn't use keyword.URL anymore but the selected search engine in the search box. You can get the old behavior back by installing this add-on: https://addons.mozilla.org/de/firefox/addon/keywordurl-hack/

Closing this back as invalid because the current behavior is by design.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
Flags: needinfo?(justintjacob)
You need to log in before you can comment on or make changes to this bug.