Cannot use Silverlight 4 drag-and-drop capability (AllowDrop) without altering the configuration of Firefox

RESOLVED DUPLICATE of bug 574991

Status

()

--
major
RESOLVED DUPLICATE of bug 574991
9 years ago
9 years ago

People

(Reporter: serious.seb, Unassigned)

Tracking

1.9.2 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6 ( .NET CLR 3.5.30729; .NET4.0E)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6 ( .NET CLR 3.5.30729; .NET4.0E)

Silverlight 4 allows the user to drag-and-drop data from outside the browser to the silverlight application.
This functionality is enabled through the use of the "AllowDrop" property on an element, a "Grid" for example.
It worked fine with previous versions but is broken with Firefox 3.6.

Reproducible: Always

Steps to Reproduce:
1. Create a new Silverlight 4 project with VS2010
2. Set the "AllowDrop" property on the automatically created "Grid", to end with the following MainPage.xaml :
<UserControl x:Class="Firefox36AllowDropBug.MainPage"
    xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
    xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
    xmlns:d="http://schemas.microsoft.com/expression/blend/2008"
    xmlns:mc="http://schemas.openxmlformats.org/markup-compatibility/2006"
    mc:Ignorable="d"
    d:DesignHeight="300" d:DesignWidth="400">

    <Grid x:Name="LayoutRoot" Background="White" AllowDrop="True">

    </Grid>
</UserControl>
3. Start debugging with Firefox
Actual Results:  
You should obtain the following error (french here, sorry) :
Erreur : Unhandled Error in Silverlight Application Échec de l'assignation à la propriété 'System.Windows.UIElement.AllowDrop'. [Line: 9 Position: 60]   à System.Windows.Application.LoadComponent(Object component, Uri resourceLocator)
   à Firefox36AllowDropBug.MainPage.InitializeComponent()
   à Firefox36AllowDropBug.MainPage..ctor()
   à Firefox36AllowDropBug.App.Application_Startup(Object sender, StartupEventArgs e)
   à MS.Internal.CoreInvokeHandler.InvokeEventHandler(Int32 typeIndex, Delegate handlerDelegate, Object sender, Object args)
   à MS.Internal.JoltHelper.FireEvent(IntPtr unmanagedObj, IntPtr unmanagedObjArgs, Int32 argsTypeIndex, String eventName)
Fichier Source : file:///C:/Documents%20and%20Settings/admin/My%20Documents/Visual%20Studio%202008/Projects/admin/TestSilverlightDataForm/Firefox36AllowDropBug/Bin/Debug/Firefox36AllowDropBugTestPage.html
Ligne : 0

Then drag-and-drop operations on the Grid are not supported anymore.

Expected Results:  
No error should be raised and the "Grid" should accept drop.

Silverlight version : 4.0.50401.0
Windows version : XP Pro SP3
(Reporter)

Comment 1

9 years ago
A workaround is described here :
http://forums.silverlight.net/forums/p/188959/434818.aspx#434818

But it's not possible to update users' configuration or to ask them not to migrate to Firefox 3.6.6.
Component: General → Plug-ins
Product: Firefox → Core
QA Contact: general → plugins
Version: unspecified → 1.9.2 Branch

Comment 2

9 years ago
I can confirm this
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

9 years ago
Confirmed here as well, using the Silverlight Toolkit's ListBoxDragDropTarget control as well.  It doesn't always crash the plugin, but it nearly always stops further plugin processing.

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 574991
You need to log in before you can comment on or make changes to this bug.