Firefox 4.0b1 Crash Report [@ nsTArray<mozilla::layers::ThebesLayerD3D9*>::Clear() ]

RESOLVED WORKSFORME

Status

()

Core
Graphics
--
critical
RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: aravindm, Unassigned)

Tracking

({crash})

Trunk
x86
Windows XP
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [4b1], crash signature, URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:2.0b1) Gecko/20100628 Firefox/4.0b1

Steps to reproduce : 
1. Open http://videos.mozilla.org/firefox/3.6/getpersonas.ogv
2. Context on the video and Select Full screen mode

Actual Result : Firefox Crashes when entering full screen mode

Expected Result : Firefox should open in full screen mode and play as normal

Crash Stats : 
http://crash-stats.mozilla.com/report/index/4e06a774-88d0-45bd-90c1-314f02100629
http://crash-stats.mozilla.com/report/index/bp-1d15c654-f6de-49a7-9512-abe982100629
http://crash-stats.mozilla.com/report/index/bp-c7b55397-dda1-4d2b-8d5f-98c272100629
http://crash-stats.mozilla.com/report/index/f2b94ab3-3d7b-4b25-a29b-b01912100629
I have not been able to recreate the problem on a new installation with a clean profile on an XP vm, yet.
Adding Jeff and Joe, says D3D9 right in the stacks!
Component: General → Graphics
Product: Firefox → Core
QA Contact: general → thebes
It might be just me, but I can only find one nsTArray<mozilla::layers::ThebesLayerD3D9> in our code. And we never call clear on that. I wonder what's going on here, the stack also looks really weird. I wonder if this is a root layer ownership issue.
Not able to reproduce on Windows XP either using the beta 1 build 2 candidate build. Would be good to get some information about what hardware aravind is using.
(Reporter)

Comment 6

8 years ago
System Config details:
Operating System:
Windows XP Professional Service Pack 2 (build 2600)
Install Language: English (United States)
System Locale: English (United States) 	  	

System Model:
Dell Inc. OptiPlex GX620

Processor:
3.00 gigahertz Intel Pentium 4
16 kilobyte primary memory cache
2048 kilobyte secondary memory cache
64-bit ready
Hyper-threaded (2 total)

Display:
Intel(R) 82945G Express Chipset Family [Display adapter] (2x)
LG 700E [Monitor] (16.3"vis, March 2004)

Multimedia:
SoundMAX Integrated Digital Audio

Memory:
1016 Megabytes Usable Installed Memory
(Reporter)

Comment 7

8 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:2.0b1) Gecko/20100630 Firefox/4.0b1
Able to reproduce the crashes in firefox 4.0b1(build 2 ) also. In Linux machine, when i try to play in full screen, firefox hangs. Need to force quit firefox and reopen again.
Crash Reports : 
http://crash-stats.mozilla.com/report/index/bp-eeff40e5-cfcc-4d4c-b800-3b13d2100701
http://crash-stats.mozilla.com/report/index/bp-d8008e38-73e3-406f-9459-968e92100701
(Reporter)

Comment 8

8 years ago
Created attachment 455630 [details]
Installed plugins

Updated

8 years ago
Severity: normal → critical
Keywords: crash
Summary: Firefox 4.0b1 Crash Report [@ nsTArray<mozilla::layers::ThebesLayerD3D9*>::Clear() → Firefox 4.0b1 Crash Report [@ nsTArray<mozilla::layers::ThebesLayerD3D9*>::Clear() ]
I think we'll need a better stack before we can figure out what's going on here.
(Assignee)

Updated

7 years ago
Crash Signature: [@ nsTArray<mozilla::layers::ThebesLayerD3D9*>::Clear() ]
There haven't been any such crashes in the last 2 weeks, so I think we're OK here.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.