Closed Bug 575586 Opened 9 years ago Closed 9 years ago

[LongTap]Fennec does not pass long tap event to plug-ins

Categories

(Firefox for Android Graveyard :: General, defect)

All
Linux
defect
Not set

Tracking

(fennec-)

RESOLVED FIXED
Tracking Status
fennec - ---

People

(Reporter: ilkka.otsala, Assigned: romaxa)

References

()

Details

(Whiteboard: [flash])

Attachments

(3 files, 3 obsolete files)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.19) Gecko/2010040119 Ubuntu/8.04 (hardy) Firefox/3.0.19
Build Identifier: Mozilla/5.0 (X11; U; Linux armv7l; en-US; rv:1.9.3a5pre) Gecko/20100622 Firefox/ Fennec/2.0a1pre

If a long tap gesture is done on top of e.g. flash content, a right click event should be passed to plug-in for context sensitive menu purposes.

Reproducible: Always

Steps to Reproduce:
1. Load page that contains flash e.g. youtube.com 
2. make long tap gesture on top of flash content

Actual Results:  
Nothing happens.

Expected Results:  
Flash context sensitive menu should be popped up.
I suppose it would be useful for context sensitive add-ons too: They could alter the context menu depending on context.
Whiteboard: [flash]
Blocks: 584225
Assignee: nobody → jap
Attachment #468015 - Flags: review?(mark.finkle)
Status: UNCONFIRMED → NEW
Ever confirmed: true
tracking-fennec: --- → ?
Waiting until we have plugins working in Fennec again before reviewing this patch.
Summary: Fennec does not pass long tap event to plug-ins → [LongTap]Fennec does not pass long tap event to plug-ins
not blocking fennec, but we'll take a patch if and when plugins work and it can be tested.
tracking-fennec: ? → 2.0-
This is an update to the previous patch. It should work with the Fennec's updated CSM handling code.

However, I believe that csm for embedded elements, like flash, will still be broken when the embedded element is located at a position which needs panning.  I think that fix for the bug 607881 (or similar) could resolve the issue.
Attachment #486888 - Flags: review?(mark.finkle)
Plugins are testable...
Install youtube enabler extension or just enable it with prefs
Attachment #468015 - Attachment is obsolete: true
Attachment #486888 - Attachment is obsolete: true
Attachment #503796 - Flags: review?(mark.finkle)
Attachment #468015 - Flags: review?(mark.finkle)
Attachment #486888 - Flags: review?(mark.finkle)
Don't know is it blocking or depends from bug 625673
Attachment #503796 - Attachment is obsolete: true
Attachment #503852 - Flags: review?(mark.finkle)
Attachment #503796 - Flags: review?(mark.finkle)
Attachment #503854 - Flags: review?
Attachment #503854 - Flags: review? → review?(mark.finkle)
Attachment #503852 - Flags: review?(mark.finkle) → review?(mbrubeck)
Attachment #503854 - Flags: review?(mark.finkle) → review?(mbrubeck)
Comment on attachment 503852 [details] [diff] [review]
maemo only now, and use sendMouseEvent

>+++ b/chrome/content/content.js

>+        let popupNode = element;

Why create a new variable?  Looks like you should just use "element".

>+        let embeddedNode =
>+          popupNode.nodeType == Ci.nsIDOMNode.ELEMENT_NODE &&
>+          popupNode instanceof Ci.nsIDOMHTMLEmbedElement;
>+        if (embeddedNode) {

Do you need both checks here, or could you just do "if (element instanceOf Ci.nsIDOMHTMLEmbedElement)"?

>+    if (!aButton) {
>+      aButton = 0;
>+    }

Nit: Please remove the {}, and move this block to the very top of the function.

r=mbrubeck with those changes.
Attachment #503852 - Flags: review?(mbrubeck) → review+
Attachment #503854 - Flags: review?(mbrubeck) → review+
Comment on attachment 503852 [details] [diff] [review]
maemo only now, and use sendMouseEvent

>diff --git a/chrome/content/content.js b/chrome/content/content.js

>+    if (!aButton) {
>+      aButton = 0;
>+    }

Change to:
aButton = aButton || 0;
Attached patch Updated patchSplinter Review
http://hg.mozilla.org/mobile-browser/rev/eee69f727a24
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Assignee: jap → romaxa
You need to log in before you can comment on or make changes to this bug.