If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

IMAP folder size sometimes incorrect when CONDSTORE enabled

RESOLVED DUPLICATE of bug 548584

Status

MailNews Core
Networking: IMAP
RESOLVED DUPLICATE of bug 548584
7 years ago
7 years ago

People

(Reporter: Phil Pishioneri, Assigned: Bienvenu)

Tracking

1.9.2 Branch
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [bienvenu to investigate])

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.4) Gecko/20100608 Thunderbird/3.1

Using the "Extra Folder Columns" add-on to enable viewing the folder sizes of IMAP folders.

Sometimes the reported size of folders is incorrect: the size given will always be smaller than the actual size, never larger. Not all folders will have an incorrect size. Rebuilding (repairing in 3.1) the folder will restore the correct size, but it may change to an incorrect value at a later time. Was verifying correct folder sizes by directly examining the IMAP files on the IMAP server.

Disabling CONDSTORE (mail.server.default.use_condstore) fixes the problem: if a folder with an incorrect size is repaired, it will report the correct value and continue to so (have tested with condstore disabled for several days without seeing incorrect values).

IMAP Server: dovecot 1.2.11. Problem has existed with all v3.x thunderbirds, not just 3.1.

The folders with incorrect values may only be ones to which Thunderbird has filters to move messages into them, but don't know for certain.

When I had a version 2 build of thunderbird running simultaneously, it would be reporting correct values while a v3 client has some incorrect values.

Reproducible: Sometimes

Steps to Reproduce:
1. Install "Extra Folder Columns" add-on, enable viewing folder sizes.
2. See some folders report incorrect values.
Actual Results:  
Some folders report incorrect sizes, sometimes.

Expected Results:  
Folders always report correct sizes.
(Reporter)

Updated

7 years ago
Version: unspecified → 3.1
I think we fixed all the condstore related issues in 3.1, we don't force the repair  on update though.
(Reporter)

Comment 2

7 years ago
(In reply to comment #1)
> I think we fixed all the condstore related issues in 3.1,

I thought that I verified the problem still existed on 3.1 just prior to submitting the bug, but will watch for several days to see. Perhaps I just had not repaired all of the folders with suspect values.
status-thunderbird3.1: --- → ?
Component: Folder and Message Lists → Networking: IMAP
Product: Thunderbird → MailNews Core
QA Contact: folders-message-lists → networking.imap
Version: 3.1 → 1.9.2 Branch
So David thought he'd fixed this for 3.1 beta 2 in bug 548584, David can you take a look please?
Assignee: nobody → bienvenu
Whiteboard: [bienvenu to investigate]
(Reporter)

Comment 4

7 years ago
Having run for a couple of weeks and not seen any new incorrect sizes, I just may not have repaired the folders which still had the old, incorrect values.

If this is closed "invalid" or such I'm OK with that.
(Assignee)

Comment 5

7 years ago
ok, thx, marking dup. Please re-open if you see it again.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 548584
status-thunderbird3.1: ? → ---
You need to log in before you can comment on or make changes to this bug.