If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

The sel_spd test hangs on some HP-UX 11.00 machines.

RESOLVED FIXED

Status

NSPR
NSPR
P3
normal
RESOLVED FIXED
19 years ago
18 years ago

People

(Reporter: Wan-Teh Chang, Assigned: Wan-Teh Chang)

Tracking

({pp})

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

19 years ago
The OS is HP-UX B.11.00, 32-bit mode.  The
test machine is nugget.mcom.com.  The NSPR
release is 3.1.1.

The sel_spd test hangs on nugget.mcom.com
(both debug and optimized builds).  However,
it does not hang when running on the machine
orville.mcom.com.

By the way, orville.mcom.com is a 4-CPU machine.
I don't know how many CPUs nugget.mcom.com has.
(Assignee)

Comment 1

19 years ago
This bug may be related to bug #5789:
The sel_spd test (optimized build) hangs on AIX 4.2.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED

Updated

19 years ago
Summary: The sel_spd test hangs on some HP-UX 11.00 machines. → [PP]The sel_spd test hangs on some HP-UX 11.00 machines.

Updated

18 years ago
Keywords: pp

Updated

18 years ago
Summary: [PP]The sel_spd test hangs on some HP-UX 11.00 machines. → The sel_spd test hangs on some HP-UX 11.00 machines.
(Assignee)

Comment 2

18 years ago
The bug is in the test itself.  The test calls
PR_Wait without checking the predicate
(_thread_exit_count > 0).  So if _thread_exit_count
is 0, the PR_Wait call will never return.

The fix is to add a while loop around the PR_Wait
call.

/cvsroot/mozilla/nsprpub/pr/tests/sel_spd.c, revision 3.9
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 3

18 years ago
*** Bug 5789 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.