Status

()

VERIFIED DUPLICATE of bug 596720
8 years ago
8 years ago

People

(Reporter: blizzard, Assigned: bjacob)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(blocking2.0 beta7+)

Details

(Reporter)

Description

8 years ago
Let's get it enabled on mozilla-central and ship this puppy.
(Reporter)

Updated

8 years ago
Blocks: 569993
Assignee: nobody → vladimir

Comment 1

8 years ago
Should this be turned into a meta-bug where we collect bugs that are serious enough to prevent us from enabling WebGL by default?
(Reporter)

Updated

8 years ago
Depends on: 584536
(Reporter)

Updated

8 years ago
Depends on: 584541
(Reporter)

Updated

8 years ago
Depends on: 584544
(Reporter)

Updated

8 years ago
Depends on: 584179
(Reporter)

Updated

8 years ago
Depends on: 584547
(Reporter)

Updated

8 years ago
Depends on: 586048

Comment 2

8 years ago
If we're going to do this for FF4, it needs to hit beta5 feature freeze. Marking that as the current plan, although I don't see how we actually have the resources to do this and I think we should cut it.
blocking2.0: --- → beta5+
(Assignee)

Comment 3

8 years ago
Why should be cut it? Vlad and myself are working on it.
(Assignee)

Updated

8 years ago
Assignee: vladimir → nobody
Component: Graphics → Canvas: WebGL
QA Contact: thebes → canvas.webgl
Depends on: 589265
(Assignee)

Comment 4

8 years ago
A little status update. As far as I know, there are 2 major blockers here:

1) WebGL must be covered by a mochitest. Fortunately, bug 582053 does exactly that. I just attached a hopefully final version of my patch, so, hopefully this will be checked in soon.

2) Security-wise, we need a driver blacklist. However I don't think that this issue should be blocking beta5, only final.

So, I guess that we should do things in this order:
 - get bug 582053 checked in
 - enable WebGL by default
 - implement the driver blacklising (not necessarily before beta5).

Is this OK?
(Assignee)

Comment 5

8 years ago
Great, bug 584536 is already taking care of the driver blacklist/whitelist, and is already tagged as blocking this one.
(Assignee)

Updated

8 years ago
Assignee: nobody → bjacob
Depends on: 589546
(Assignee)

Comment 6

8 years ago
This was marked as blocking beta5. Now that the feature freeze is shifted to sep. 10, I guess this is our new target.
blocking2.0: beta5+ → ?
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 596720

Updated

8 years ago
No longer blocks: 569993
No longer depends on: 582053, 584541, 584544, 589265, 589546, 584179, 584536, 584547, 586048

Updated

8 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.