Error(s) when scrolling up on an empty history

RESOLVED INVALID

Status

Skywriter
Command Line
RESOLVED INVALID
8 years ago
7 years ago

People

(Reporter: Mark Spear, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US) AppleWebKit/534.1 (KHTML, like Gecko) Chrome/6.0.437.3 Safari/534.1
Build Identifier: tip (changeset:   1980:f583805647a7)

Depending on what browser you use (and whether you have Firebug), the resulting error can vary a little bit:

Chrome, in the CLI history: "TypeError: Cannot read property 'typed' of undefined"
FF w/ Firebug, in the CLI history: "TypeError: history.requests[pointer] is undefined"

In the console: "Error executing command 'undefined'"
FF no Firebug, "console is not defined" is shown in the Error Console

Reproducible: Always

Steps to Reproduce:
1. Load up bespin
2. Give the CLI focus
3. Press up
Actual Results:  
Errors appear as described above

Expected Results:  
No errors. It could be debated whether it should env.commandLine.setInput('') or keep the currently typed input. I elected to keep the currently typed input, as that seems to be the behaviour of bash.
(Reporter)

Comment 1

8 years ago
Created attachment 454939 [details] [diff] [review]
Fix error(s) from pressing up in the CLI when your history is empty

Comment 2

7 years ago
ACETRANSITION

The Skywriter project has merged with Ajax.org's Ace project (the full server part of which is their Cloud9 IDE project). Background on the change is here:

http://mozillalabs.com/skywriter/2011/01/18/mozilla-skywriter-has-been-merged-into-ace/

The bugs in the Skywriter product are not necessarily relevant for Ace and quite a bit of code has changed. For that reason, I'm closing all of these bugs. Problems that you have with Ace should be filed in the Ace issue tracker at GitHub:

https://github.com/ajaxorg/ace/issues
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.