[CBX]<SELECT>'s with <OPTGROUP>'s never take focus

VERIFIED WORKSFORME

Status

()

Core
Layout: Form Controls
P3
normal
VERIFIED WORKSFORME
18 years ago
17 years ago

People

(Reporter: Blake Ross, Assigned: rods (gone))

Tracking

Trunk
Future
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
Build ID: new trunk

Steps to Reproduce:

(1) Debug > Viewer Demos > #8 Form (resource:///res/samples/test8.html)
(2) Scroll down to "Optgroup Test"
(3) Click in the URL bar
(4) Click in the listbox under "Select size=4 with Optgroup (Listbox)"
(5) Click "dead" area of the page (e.g. just text)
(6) Click the listbox (under "Select size=4 with Optgroup (Listbox)")
(7) Click another listbox
(8) Click the listbox (under "Select size=4 with Optgroup (Listbox)")

Result: the listbux under "Select size=4 with Optgroup (Listbox)" never 
actually takes the focus, as evidenced by (1) the fact that the cursor never 
stops blinking in the URL bar after step 4 and (2) the fact that the up/down 
arrow keys never work to scroll that listbox...instead they either move the 
caret left and right in the URL bar after step 4, or they scroll the page up 
and down after step 6, or they scroll the other listbox (that you click in step 
7) after step 8.
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Summary: <SELECT>'s with <OPTGROUP>'s never take focus → [CBX]<SELECT>'s with <OPTGROUP>'s never take focus
Target Milestone: --- → Future
(Assignee)

Comment 1

17 years ago
works for me
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 2

17 years ago
Verified build 2001082703 os:win98
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.