Quick filter bar search results colors do not match high contrast black color scheme

RESOLVED FIXED in Thunderbird 3.3a1

Status

defect
--
major
RESOLVED FIXED
9 years ago
8 years ago

People

(Reporter: d2ogilvi, Assigned: andreasn)

Tracking

({access})

Thunderbird 3.3a1
x86
Windows XP
Bug Flags:
wanted-thunderbird +

Firefox Tracking Flags

(blocking-thunderbird3.1 -, thunderbird3.1 wontfix)

Details

Attachments

(2 attachments)

Reporter

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6 (.NET CLR 3.5.30729)
Build Identifier: Thunderbird 3.1

Set Windows color scheme to "High Contrast Black"
Start Thunderbird
Make sure there are messages to search in the current folder (such as inbox)
Type a search string in the "Filter these messages" or "search all messages" field.
Search results come out as white text on a white background.


Reproducible: Always

Steps to Reproduce:
1. see above
2.
3.
Actual Results:  
See above

Expected Results:  
Background colour should be black (Window background) as defined in the "Hogh Contrast Black" colour scheme.
Flags: wanted-thunderbird+

Comment 1

9 years ago
I can confirm this. It is a major for me so I'm hoping it can be fixed quickly. I will try to add a screenshot. It also happens in the Quick Search.

The same problem has been reported for Lightning/Calandar Bug 435096 which I'm also hoping can be fixed quickly.
is this seen also in v3.0? or did you skip from 2.0.x to 3.1?

similar, but far worse than bug 549634 (at least comparing screen shots)
blocking-thunderbird3.1: --- → ?
Keywords: access
Version: unspecified → 3.1

Comment 4

9 years ago
Yes. I used all the releases of 3.0.x up to 3.0.5 before going to 3.1. Had the problem with all of them.

Comment 5

9 years ago
Sorry. Ignore that last comment. I did use all the releases of 3.0.x but this problem is NEW with 3.1. (got confused with the bug I reported earlier today which started with 3.0 and is still present - concerns assigning apps to attachment types)
Andreas, can you take a look at this?
Assignee: nobody → nisses.mail
blocking-thunderbird3.1: ? → needed
Assignee

Comment 7

9 years ago
I can confirm this. Fix coming up shortly!
Status: UNCONFIRMED → NEW
Ever confirmed: true
Reporter

Comment 8

9 years ago
This bus is still present in TB 3.1.2, in case anyone needed to know!  :)
Reporter

Comment 9

9 years ago
This bug is still present in TB 3.1.2, if anyone needed to know!  :)
(In reply to comment #9)
> This bug is still present in TB 3.1.2, if anyone needed to know!  :)

The bug is still open and is tracked on our branch list. We don't need additional comments unless it has been fixed by something else. Thanks.
Assignee

Comment 11

9 years ago
This unfortunately makes the filtering worse in non-a11y mode, since you won't get the nice stripe visuals in the background for none found for example.
Is there anything like -moz-system-metric for HighContrast built into Gecko?
Assignee

Comment 12

9 years ago
Comment on attachment 464058 [details] [diff] [review]
working treeviews in a11y mode

Asking for ui-review. Andrew said this probably don't need code review.
Attachment #464058 - Flags: ui-review?(clarkbw)
Assignee

Updated

9 years ago
Duplicate of this bug: 593070

Comment 14

9 years ago
If there is a -moz-system-metric, using it would not fix this particular bug.

High contrast mode != high contrast color theme. You need to compare the text color to black instead to decide which path to use.
Comment on attachment 464058 [details] [diff] [review]
working treeviews in a11y mode

This seems to take away from the non-a11y mode but I guess there's not much choice.
Attachment #464058 - Flags: ui-review?(clarkbw) → ui-review+
Assignee

Updated

9 years ago
Keywords: checkin-needed
Checked in: http://hg.mozilla.org/comm-central/rev/0d149474d3a1
Status: NEW → RESOLVED
Closed: 9 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.3a1

Comment 17

8 years ago
This has NOT been fixed and is still present in TB5. I could send another screen shot but it would be identical to the original one I psoted.

Comment 18

8 years ago
PS. Using Windows 7 64bit now.
BJ, can you file a new bug please?    Please cite your theme.
This bug won't be reopened because it already has a patch that landed long ago.
p.s. and please clarify whether you are referring to quick filter bar or search all messages.  If search all messages is your issue, then please refer to Bug 549634 - [faceted search] Make faceted search results window handle High Contrast mode
Summary: When in search screen colors do not match high contrast black color scheme → Quick filter bar search results colors do not match high contrast black color scheme

Comment 21

8 years ago
Wayne,


It's exactly as given in this closed bug. It's the Quick Filter Bar when used with the High Contrast Black theme. But this time under Win 7 instead of XP.

It's exactly the same. I'll open a new bug report.

Bruce

Comment 22

8 years ago
Where's the new bug? No build was shipped with this fixed.
blocking-thunderbird3.1: needed → -
You need to log in before you can comment on or make changes to this bug.