The test of testEliminatedGuardWithinAnchor.js failed on SPARC in TraceMonkey

RESOLVED WONTFIX

Status

()

Core
JavaScript Engine
RESOLVED WONTFIX
8 years ago
6 years ago

People

(Reporter: elaine, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.9.2.3) Gecko/20100412 Firefox/3.6.3
Build Identifier: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.9.2.3) Gecko/20100412 Firefox/3.6.3

The actual test result on SPARC only has 1 trace instead of 3 on x86 because there is no integer div/mod on SPARC. ARM has the same issue fixed at #517332 . It is not sure if PowerPC has the same issue or not, so the patch attached only resolves SPARC case.

Reproducible: Always
(Reporter)

Comment 1

8 years ago
Created attachment 455107 [details] [diff] [review]
fix the failure on SPARC
(Reporter)

Updated

8 years ago
Component: General → JavaScript Engine
Product: Firefox → Core
Assignee: nobody → general
QA Contact: general → general
Attachment #455107 - Flags: review+

Updated

7 years ago
Duplicate of this bug: 572490
Obsolete with the removal of tracejit.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.