PROCESS-CRASH | nptest.dll!IntentionalCrash [nptest.cpp:8f64c2eeb40e : 103 + 0x6]

VERIFIED DUPLICATE of bug 539823

Status

()

Core
IPC
VERIFIED DUPLICATE of bug 539823
8 years ago
6 years ago

People

(Reporter: romaxa, Unassigned)

Tracking

({intermittent-failure})

Other Branch
x86
Windows NT
intermittent-failure
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=MozillaTry/1277894553.1277895582.18789.gz#err0

14422 INFO TEST-START | Shutdown
14423 INFO Passed: 13476
14424 INFO Failed: 0
14425 INFO Todo:   113
14426 INFO SimpleTest FINISHED
*** registerContentHandler(application/vnd.mozilla.maybe.feed,http://mochi.test:8888/tests/toolkit/components/places/tests/chrome/demohandler.html?feedurl=%s,Demo handler)

###!!! [Parent][RPCChannel] Error: Channel error: cannot send/recv


###!!! [Parent][RPCChannel] Error: Channel error: cannot send/recv


###!!! [Parent][RPCChannel] Error: Channel error: cannot send/recv


###!!! [Parent][RPCChannel] Error: Channel error: cannot send/recv

INFO | automation.py | Application ran for: 0:04:17.843000
INFO | automation.py | Reading PID log: c:\docume~1\cltbld\locals~1\temp\tmp230culpidlog
==> process 2476 launched child process 1952
==> process 2476 launched child process 2776
==> process 2476 launched child process 1204
==> process 2476 launched child process 1720
==> process 2476 launched child process 2792
INFO | automation.py | Checking for orphan process with PID: 1952
INFO | automation.py | Checking for orphan process with PID: 2776
INFO | automation.py | Checking for orphan process with PID: 1204
INFO | automation.py | Checking for orphan process with PID: 1720
INFO | automation.py | Checking for orphan process with PID: 2792
NEXT ERROR PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Operating system: Windows NT
                  5.2.3790 Service Pack 2
CPU: x86
     GenuineIntel family 6 model 23 stepping 8
     1 CPU

Crash reason:  EXCEPTION_ACCESS_VIOLATION
Crash address: 0x0

NEXT ERROR Thread 0 (crashed)
 0  nptest.dll!IntentionalCrash [nptest.cpp:8f64c2eeb40e : 103 + 0x6]
    eip = 0x010d163a   esp = 0x0012f674   ebp = 0x0012f690   ebx = 0x00854aa0
    esi = 0x0085a520   edi = 0x0012f6d8   eax = 0x00000000   ecx = 0x0012f634
    edx = 0x00010001   efl = 0x00010202
    Found by: given as instruction pointer in context
 1  nptest.dll!crashPlugin [nptest.cpp:8f64c2eeb40e : 2295 + 0x4]
    eip = 0x010d3cc3   esp = 0x0012f678   ebp = 0x0012f690
    Found by: call frame info
 2  nptest.dll!scriptableInvoke(NPObject *,void *,_NPVariant const *,unsigned int,_NPVariant *) [nptest.cpp:8f64c2eeb40e : 1600 + 0x10]
    eip = 0x010d2eaf   esp = 0x0012f67c   ebp = 0x0012f690
    Found by: call frame info
 3  xul.dll!mozilla::plugins::PluginScriptableObjectChild::AnswerInvoke(mozilla::plugins::PPluginIdentifierChild *,nsTArray<mozilla::plugins::Variant> const &,mozilla::plugins::Variant *,bool *) [PluginScriptableObjectChild.cpp:8f64c2eeb40e : 710 + 0x33]
    eip = 0x107e4804   esp = 0x0012f698   ebp = 0x0012f7c0
    Found by: previous frame's frame pointer
 4  xul.dll!mozilla::plugins::PPluginScriptableObjectChild::OnCallReceived(IPC::Message const &,IPC::Message * &) [PPluginScriptableObjectChild.cpp:8f64c2eeb40e : 699 + 0x21]
    eip = 0x107e3179   esp = 0x0012f7c8   ebp = 0x0012f810
    Found by: previous frame's frame pointer
 5  xul.dll!mozilla::plugins::PPluginModuleChild::OnCallReceived(IPC::Message const &,IPC::Message * &) [PPluginModuleChild.cpp:8f64c2eeb40e : 460 + 0xa]
    eip = 0x107e362e   esp = 0x0012f818   ebp = 0x0012f84c
    Found by: previous frame's frame pointer
 6  xul.dll!mozilla::ipc::RPCChannel::DispatchIncall(IPC::Message const &) [RPCChannel.cpp:8f64c2eeb40e : 510 + 0x14]
    eip = 0x10656f41   esp = 0x0012f854   ebp = 0x0012f87c
    Found by: previous frame's frame pointer
 7  xul.dll!mozilla::ipc::RPCChannel::Incall(IPC::Message const &,unsigned int) [RPCChannel.cpp:8f64c2eeb40e : 496 + 0x6]
    eip = 0x1065708a   esp = 0x0012f884   ebp = 0x0012f8ec
    Found by: previous frame's frame pointer
 8  xul.dll!mozilla::ipc::RPCChannel::OnMaybeDequeueOne() [RPCChannel.cpp:8f64c2eeb40e : 434 + 0xe]
    eip = 0x1065c62c   esp = 0x0012f8a0   ebp = 0x0012f8ec
    Found by: call frame info
 9  xul.dll!MessageLoop::RunTask(Task *) [message_loop.cc:8f64c2eeb40e : 339 + 0x6]
    eip = 0x1026ff6d   esp = 0x0012f8f4   ebp = 0x0012f948
    Found by: previous frame's frame pointer
10  xul.dll!MessageLoop::DeferOrRunPendingTask(MessageLoop::PendingTask const &) [message_loop.cc:8f64c2eeb40e : 347 + 0x6]
    eip = 0x1026ff4d   esp = 0x0012f8fc   ebp = 0x0012f948
    Found by: call frame info
11  xul.dll!MessageLoop::DoWork() [message_loop.cc:8f64c2eeb40e : 447 + 0xa]
    eip = 0x101017b1   esp = 0x0012f90c   ebp = 0x0012f948
    Found by: call frame info
12  xul.dll!base::MessagePumpForUI::DoRunLoop() [message_pump_win.cc:8f64c2eeb40e : 213 + 0x6]
    eip = 0x1066ced7   esp = 0x0012f950   ebp = 0x0012f974
    Found by: previous frame's frame pointer
13  xul.dll!base::MessagePumpWin::RunWithDispatcher(base::MessagePump::Delegate *,base::MessagePumpWin::Dispatcher *) [message_pump_win.cc:8f64c2eeb40e : 52 + 0x6]
    eip = 0x1027247e   esp = 0x0012f960   ebp = 0x0012f974
    Found by: call frame info with scanning
14  xul.dll!base::MessagePumpWin::Run(base::MessagePump::Delegate *) [message_pump_win.h:8f64c2eeb40e : 78 + 0xb]
    eip = 0x10272490   esp = 0x0012f97c   ebp = 0x0012f9c0
    Found by: previous frame's frame pointer
15  xul.dll!MessageLoop::RunInternal() [message_loop.cc:8f64c2eeb40e : 219 + 0x8]
    eip = 0x10248930   esp = 0x0012f984   ebp = 0x0012f9c0
    Found by: call frame info with scanning
16  xul.dll!MessageLoop::RunHandler() + 0x10
    eip = 0x1041f9e9   esp = 0x0012f990   ebp = 0x0012f9c0
    Found by: call frame info
17  xul.dll!MessageLoop::Run() [message_loop.cc:8f64c2eeb40e : 176 + 0x6]
    eip = 0x102488c1   esp = 0x0012f9c8   ebp = 0x0012f9f8
    Found by: previous frame's frame pointer
18  xul.dll!XRE_InitChildProcess [nsEmbedFunctions.cpp:8f64c2eeb40e : 453 + 0xb]
    eip = 0x10800eba   esp = 0x0012fa00   ebp = 0x0012ff40
    Found by: previous frame's frame pointer
19  plugin-container.exe!wmain [nsWindowsWMain.cpp:8f64c2eeb40e : 120 + 0x40]
    eip = 0x0040125b   esp = 0x0012ff48   ebp = 0x0012ff80
    Found by: previous frame's frame pointer
20  plugin-container.exe!__tmainCRTStartup [crtexe.c:8f64c2eeb40e : 591 + 0x18]
    eip = 0x00401412   esp = 0x0012ff88   ebp = 0x0012ffc0
    Found by: previous frame's frame pointer
21  kernel32.dll + 0x2f23a
    eip = 0x77e6f23b   esp = 0x0012ffc8   ebp = 0x0012fff0   ebx = 0x7ffff000
    Found by: call frame info

Thread 1
 0  ntdll.dll + 0x285ec
    eip = 0x7c8285ec   esp = 0x00f8fea4   ebp = 0x00f8ff48   ebx = 0x00f8fef0
    esi = 0x00000002   edi = 0x00000000   eax = 0x7c80e1fa   ecx = 0x00000000
    edx = 0x00000000   efl = 0x00000246
    Found by: given as instruction pointer in context
 1  ntdll.dll + 0xe4a1
    eip = 0x7c80e4a2   esp = 0x00f8ff50   ebp = 0x00f8ffb8
    Found by: previous frame's frame pointer
 2  kernel32.dll + 0x24828
    eip = 0x77e64829   esp = 0x00f8ffc0   ebp = 0x00f8ffec
    Found by: previous frame's frame pointer

Thread 2
 0  ntdll.dll + 0x285ec
    eip = 0x7c8285ec   esp = 0x010cfd88   ebp = 0x010cfdb4   ebx = 0x00000000
    esi = 0x010cfdf8   edi = 0x010cfe00   eax = 0x10b37070   ecx = 0x00854880
    edx = 0x10b3e0a4   efl = 0x00000246
    Found by: given as instruction pointer in context
 1  xul.dll!base::MessagePumpForIO::GetIOItem(unsigned long,base::MessagePumpForIO::IOItem *) [message_pump_win.cc:8f64c2eeb40e : 528 + 0x24]
    eip = 0x10001a00   esp = 0x010cfdbc   ebp = 0x010cfde0
    Found by: previous frame's frame pointer
 2  xul.dll!base::MessagePumpForIO::WaitForIOCompletion(unsigned long,base::MessagePumpForIO::IOHandler *) [message_pump_win.cc:8f64c2eeb40e : 499 + 0xb]
    eip = 0x100019a9   esp = 0x010cfde8   ebp = 0x010cfe08
    Found by: previous frame's frame pointer
 3  xul.dll!base::MessagePumpForIO::WaitForWork() [message_pump_win.cc:8f64c2eeb40e : 492 + 0xb]
    eip = 0x10256831   esp = 0x010cfe10   ebp = 0x010cfe2c
    Found by: previous frame's frame pointer
 4  xul.dll!base::MessagePumpForIO::DoRunLoop() [message_pump_win.cc:8f64c2eeb40e : 477 + 0x5]
    eip = 0x1021f439   esp = 0x010cfe1c   ebp = 0x010cfe2c
    Found by: call frame info
 5  xul.dll!base::MessagePumpWin::RunWithDispatcher(base::MessagePump::Delegate *,base::MessagePumpWin::Dispatcher *) [message_pump_win.cc:8f64c2eeb40e : 52 + 0x6]
    eip = 0x1027247e   esp = 0x010cfe34   ebp = 0x010cfe48
    Found by: previous frame's frame pointer
 6  xul.dll!base::MessagePumpWin::Run(base::MessagePump::Delegate *) [message_pump_win.h:8f64c2eeb40e : 78 + 0xb]
    eip = 0x10272490   esp = 0x010cfe50   ebp = 0x010cfe94
    Found by: previous frame's frame pointer
 7  xul.dll!MessageLoop::RunInternal() [message_loop.cc:8f64c2eeb40e : 219 + 0x8]
    eip = 0x10248930   esp = 0x010cfe58   ebp = 0x010cfe94
    Found by: call frame info with scanning
 8  xul.dll!MessageLoop::RunHandler() [message_loop.cc:8f64c2eeb40e : 202 + 0x4]
    eip = 0x10248919   esp = 0x010cfe64   ebp = 0x010cfe94
    Found by: call frame info
 9  xul.dll!_IsNonwritableInCurrentImage + 0x19
    eip = 0x10317e64   esp = 0x010cfe8c   ebp = 0x010cfe94
    Found by: call frame info with scanning
10  xul.dll!MessageLoop::Run() [message_loop.cc:8f64c2eeb40e : 176 + 0x6]
    eip = 0x102488c1   esp = 0x010cfe9c   ebp = 0x010cfecc
    Found by: previous frame's frame pointer
11  xul.dll!base::Thread::ThreadMain() [thread.cc:8f64c2eeb40e : 156 + 0x8]
    eip = 0x1024885e   esp = 0x010cfed4   ebp = 0x010cffb4
    Found by: previous frame's frame pointer
12  xul.dll!`anonymous namespace'::ThreadFunc(void *) [platform_thread_win.cc:8f64c2eeb40e : 26 + 0x8]
    eip = 0x102734f8   esp = 0x010cffbc   ebp = 0x010cffec
    Found by: previous frame's frame pointer
13  kernel32.dll + 0x24828
    eip = 0x77e64829   esp = 0x010cffc0   ebp = 0x010cffec
    Found by: call frame info

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID

Updated

8 years ago
Resolution: INVALID → DUPLICATE
Duplicate of bug: 539823

Updated

8 years ago
Blocks: 438871

Updated

8 years ago
Status: RESOLVED → VERIFIED
(Assignee)

Updated

6 years ago
Keywords: intermittent-failure
(Assignee)

Updated

6 years ago
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.