[CBX]Dropdown menus are not scrolled with wheelmouse

VERIFIED FIXED in mozilla0.9

Status

()

P3
normal
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: ezh, Assigned: bryner)

Tracking

Trunk
mozilla0.9
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
1. Open the URL
2. Open the OS dropdown
3. Try to scroll it with mouse - it closes instead of scrolling it.

This is bad. I'm fighting with this bug every day - can't remember it does not
work in mozilla... :(

Build 2000102108-Mtrunk

Updated

18 years ago
Status: NEW → ASSIGNED
Summary: Dropdown menus are not scrolled with wheelmouse → [CBX]Dropdown menus are not scrolled with wheelmouse

Updated

18 years ago
Target Milestone: --- → Future

Comment 1

18 years ago
This seems to be the same as bug 57481
(Reporter)

Comment 2

18 years ago
yep, seems like it is...

*** This bug has been marked as a duplicate of 50339 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 3

18 years ago
*** Bug 57481 has been marked as a duplicate of this bug. ***

Comment 4

18 years ago
Verifying duplicate
Status: RESOLVED → VERIFIED

Comment 5

18 years ago
Is this really a dup of bug 50339? 50339 seems to deal w/menus (File, Edit,
etc.) and this one is about <select> boxes...

CC'ing Brian Ryner because he is the owner of bug 50339
(Assignee)

Comment 6

18 years ago
you're right, this is not quite a dup.  i'm going to be rewriting a large part
of the xp mousewheel code fairly soon which will fix a whole bunch of bugs --
i'll make sure this case works also.

Comment 7

18 years ago
Reopening and assigning to bryner@netscape.com so it doesn't get lost in the
shuffle...
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---

Comment 8

18 years ago
Completing reassignment... sorry for the SPAM...
Assignee: rods → bryner
Status: REOPENED → NEW
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: Future → mozilla0.9

Comment 9

18 years ago
Bug 14935 seems related to this. It's assigned to rods and is about form lists
not listening to mouse wheel messages. I cant decide if it's a dupe or not.

(Assignee)

Comment 11

18 years ago
Created attachment 20173 [details]
layout/base/public/nsIScrollableViewProvider.h
(Assignee)

Comment 12

18 years ago
the above patch fixes bugs 29244, 50339, 42313, 33733, and 57598.

Comment 13

18 years ago
Patches work very well for me on Windows, and fix all of the bugs they're 
intended to...
(Assignee)

Comment 14

18 years ago
fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Comment 15

18 years ago
Are you sure this is fixed?  When I drop down a combo box and roll the mouse
wheel, without moving the pointer off the comb box, the drop down list
disappears.  I have to move the pointer to be over the drop down list, not just
the combo box, for mouse wheel to perform as described.

Maybe I'm drumming on a design issue, so here are some good reasons why the drop
down list should scroll without the user having to move to pointer off the combo
box and onto the drop down list:
1) Clicking the combo box puts the keyboard focus onto the drop-down list (up,
down, accelerator keys work).
2) Clicking the combo box indicates that the user desires to work with its contents.
3) MS does it that way :)

Comment 16

18 years ago
Bug 62910 was just added for the problem I mentioned.

Comment 17

18 years ago
Verifying on build 2001-01-12-04-Mtrunk on Windows 98
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.