If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Context menu pops up when clicking on links

VERIFIED FIXED

Status

Fennec Graveyard
General
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: aakashd, Assigned: vingtetun)

Tracking

Dependency tree / graph

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Build id:
Mozilla/5.0 (X11; U; Linux armv71; Nokia N900; en-US; rv:2.0b2pre) Gecko/2010630 Namoroka/4.0b2pre Fennec/2.0a1pre

Steps to Reproduce:
1. Go to https://bugzilla.mozilla.org/attachment.cgi?id=454539
2. Click on the link

Actual Results:
The context menu is popped up

Expected Results:
The context menu should not be popped up
Not just in-page links; this is happening intermittently with all sorts of links.  (Summary updated.)
Summary: Context menu pops up when clicking on in-page links → Context menu pops up when clicking on links
Duplicate of this bug: 576699
Depends on: 577429
Created attachment 456448 [details] [diff] [review]
Patch

This patch does not use the plaftorm build-in click and hold functionnality (sigh) but it does not popup everywhere!
It also turn not useful to dispatch a mousedown as soon as we have a mousedown on the chrome side.
Attachment #456448 - Flags: review?(mark.finkle)
Comment on attachment 456448 [details] [diff] [review]
Patch

>diff -r 457ffb726aeb chrome/content/content.js

>+  _contextHoldTimeout: null,

You're using _contextTimeout everywhere else

>+  _startContextHoldTimeout: function startContextHoldTimeout(aElement) {

Rename to _startContextTimeout

I think we should disable the "ui.click_hold_context_menus" pref for now too.

I can make these changes and checkin
Attachment #456448 - Flags: review?(mark.finkle) → review+
pushed:
http://hg.mozilla.org/mobile-browser/rev/5e71bc8dad6b
Assignee: nobody → 21
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
missed changing the pref:
http://hg.mozilla.org/mobile-browser/rev/4e38010bf28a
Blocks: 578018
(Reporter)

Comment 7

7 years ago
verified FIXED on build:
Mozilla/5.0 (X11; U; Linux armv71; Nokia N900; en-US; rv:2.0b2pre) Gecko/2010713 Namoroka/4.0b2pre Fennec/2.0a1pre
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.