Drop down menu for "When I delete a message" displays incorrectly & "Advanced" button missing when IMAP folder names are too long

RESOLVED FIXED in Thunderbird 30.0

Status

MailNews Core
Account Manager
RESOLVED FIXED
7 years ago
4 years ago

People

(Reporter: rado, Assigned: aceman)

Tracking

Trunk
Thunderbird 30.0

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments, 1 obsolete attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.4) Gecko/20100608 Thunderbird/3.1

Under Server Settings, the drop down menu for "When I delete a message" displays incorrectly because of an IMAP folder with a name that's too long (my folder is ~36 characters). The drop down menu appears as if it should extend beyond the window and the arrow on the right-hand side of the drop down is not visible. The "Advanced..." button is no longer visible in this window, although it can be accessed by tabbing.

Reproducible: Didn't try

Steps to Reproduce:
1. Create an IMAP folder with a long name (definitely occurs with 36+ characters)
2. Go to Server Settings screen
Have you tried safe mode? (see https://support.mozillamessaging.com/en-US/kb/Safe+Mode for more information)
Component: General → Account Manager
QA Contact: general → account-manager
can you use the add attachment link above to add an screenshot ?
(Reporter)

Comment 3

7 years ago
Created attachment 457906 [details]
This is a screen shot of Account Settings that shows the problem
(Reporter)

Comment 4

7 years ago
Created attachment 457918 [details]
Safe mode screenshot
(Reporter)

Comment 5

7 years ago
Similar issue in safe mode
The "OK" and "Cancel" buttons would be visible but I can't move or re-size the window
rename the localstore.rdf file in your folder. Does the button becomes clickable with that hack ?
(Reporter)

Comment 7

7 years ago
i renamed the file to renamed.rdf. it still looks exactly the same as before. should i have renamed the file and changed the file extension too?
Nah that should have done it. I'm unfortunately out of ideas. Adding a few people that might have other ideas.

Comment 9

6 years ago
can you reproduce this using a current version of thunderbird?

if you are unable to reproduce, please close by setting stats to resolved, and resolution to WORKSFORME or another appropriate setting.

If you are able to reproduce, add new details, and a testcase if one does not already exist in the bug report.
Whiteboard: [closeme 2012-03-25]
(Assignee)

Comment 10

6 years ago
I think WADA has good knowledge of IMAP servers.
WADA, can you setup such a long folder name on an IMAP server and see if this is real?
Whiteboard: [closeme 2012-03-25] → [closeme 2012-04-25]
Checked with Tb 11.0.1, using Gmail IMAP

Parent folder name is 100 bytes long.
> 123456789A123456789B123456789C123456789D123456789E123456789F123456789G123456789H123456789I123456789J
Display at Folder selection UI(display size= 800(heiht) x 1280) :
> 123456789A123456789B123456789C123456789D123456789E123456789F123456789G1…

> Sub-folder of 123456789A123456789B123456789C
> and sub-sub-folder of 123456789A123456789B123456789C
> C:\Documents and Settings\wada\Application Data\Thunderbird\Profiles\ueihzgrp.Test\ImapMail\imap.gmail.com
>  \Test-001-1.sbd
>   \123456789A123456789B123456789C123456789D12345678fda2d1a.sbd
>    \123456789A123456789B123456789C.sbd
>     \123456789A123456789B123456789C.msf
Any folder can be shown and selefcted as expected at folder selection UI. 

> Sub-folder of 123456789A123456789B123456789C
> and sub-sub-folder of 123456789A123456789B123456789C123456789D123456789E123456789F123456789G
> C:\Documents and Settings\wada\Application Data\Thunderbird\Profiles\ueihzgrp.Test\ImapMail\imap.gmail.com
>  \Test-001-1.sbd
>   \123456789A123456789B123456789C123456789D12345678fda2d1a.sbd
>    \123456789A123456789B123456789C.sbd
>     \123456789A123456789B123456789C123456789D123456789E123456789F123456789G.msf
This sub-sub-folder is not shown at folder pane, because .msf file can't be created due to 256 bytes limitation of file path in MS Win.
However, create/subscribe is normally done, because Gmail IMAP supports long folder name(Gmail Label).
Even this case, parent folder, sub-folder, sub-sub folder is normally shown and selectable at folder selection UI. No cut of of drop down menue was observed.

When any folder was selected, "123456789A123456789…" was shown as selected Trash at Server Settings due to limitation of trash name box width . (current restriction)

i.e. WORKSFORME in my environment.

To bug opener:
Do you still see your problem in recent Tb release(as of today, Tb 11)?

Comment 12

6 years ago
Resolved per whiteboard
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
Whiteboard: [closeme 2012-04-25]

Comment 13

4 years ago
Created attachment 8333800 [details]
tb24_settings_en.png

I'm seeing this bug in TB 24.1, and the length of the longest foldername in the dropdown menu is deciding the width of the whole section.

In the attachment I've selected the folder with the longest name for each account. As you can see, with "Trash" there's no problem, but "Spamverdacht" is already too long, and thus the positioning and the size of some elements is off.

The screenshot was created with a new, empty profile with only two accounts added, no other settings have been changed.
(Assignee)

Comment 14

4 years ago
The advanced button is forced to be always to the right of the folder picker. While it could be also below it to use up the empty space there.

And also the folder picker size should be limited in some way to not expand the pane content.

I can take this.
Assignee: nobody → acelists
Status: RESOLVED → REOPENED
Component: Account Manager → Account Manager
Ever confirmed: true
Product: Thunderbird → MailNews Core
Resolution: WORKSFORME → ---
Version: unspecified → Trunk

Comment 15

4 years ago
Created attachment 8333886 [details]
tb24xp_settings_en.png

FWIW, recreating the same setup in XP doesn't show the problems in my previous screenshot, even with longer folder-names in the dropdownmenu.

So, like bug 939724, this could also be Aero-specific.
(Assignee)

Comment 16

4 years ago
Created attachment 8334095 [details] [diff] [review]
576025.patch

OK, what do you think of this?
Attachment #8334095 - Flags: ui-review?(bwinton)
Attachment #8334095 - Flags: review?(iann_bugzilla)

Comment 17

4 years ago
Comment on attachment 8334095 [details] [diff] [review]
576025.patch

Just wondering whether crop="end" would be better than crop="center"
May be worth being tested by someone whom builds on XP/Win7
Attachment #8334095 - Flags: review?(iann_bugzilla) → review+
(Assignee)

Comment 18

4 years ago
There is crop="center" at least in the toolbar folder picker widget. I have also seen crop="end" at other placing using the folder picker. I don't know which one is better but we should unify it across the whole app. I think there is a bug for that or at least I have the plan in my head ;)

Comment 19

4 years ago
This is bit rotted now (Bug 878805).
(Assignee)

Comment 20

4 years ago
Created attachment 8375005 [details] [diff] [review]
patch v2

Yes, thanks.
Attachment #8334095 - Attachment is obsolete: true
Attachment #8334095 - Flags: ui-review?(bwinton)
Attachment #8375005 - Flags: ui-review?(bwinton)
Attachment #8375005 - Flags: review?(mkmelin+mozilla)

Updated

4 years ago
Attachment #8375005 - Flags: review?(mkmelin+mozilla) → review+
Comment on attachment 8375005 [details] [diff] [review]
patch v2

This certainly seems better.  ui-r=me!
Attachment #8375005 - Flags: ui-review?(bwinton) → ui-review+
(Assignee)

Comment 22

4 years ago
Thanks.
Keywords: checkin-needed
OS: Windows 7 → All
Hardware: x86 → All
https://hg.mozilla.org/comm-central/rev/5161517dbf41
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago4 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 30.0
You need to log in before you can comment on or make changes to this bug.