updateInfoURI is not exposed and needs to be passed through to the resulting Addon

VERIFIED FIXED in mozilla2.0b2

Status

()

VERIFIED FIXED
9 years ago
9 years ago

People

(Reporter: mossop, Assigned: mossop)

Tracking

({APIchange})

Trunk
mozilla2.0b2
APIchange
Points:
---
Bug Flags:
in-testsuite +
in-litmus -

Firefox Tracking Flags

(blocking2.0 beta2+)

Details

(Whiteboard: [AddonsRewrite][schemachange])

Attachments

(1 attachment)

We don't expose the updateInfoURL property. This patch adds it to AddonInstall.infoURI and also Addon.infoURI which holds the release notes for the installed version.
(Assignee)

Comment 1

9 years ago
Created attachment 455267 [details] [diff] [review]
patch rev 1

As elsewhere I've switching this from infoURL to infoURI and made it return an nsIURI. Added some tests to make sure we can see the infoURI during update downloading and after the new version is installed.
Assignee: nobody → dtownsend
Status: NEW → ASSIGNED
Attachment #455267 - Flags: review?(robert.bugzilla)
Comment on attachment 455267 [details] [diff] [review]
patch rev 1

>diff --git a/toolkit/mozapps/extensions/XPIProvider.jsm b/toolkit/mozapps/extensions/XPIProvider.jsm
>--- a/toolkit/mozapps/extensions/XPIProvider.jsm
>+++ b/toolkit/mozapps/extensions/XPIProvider.jsm
>@@ -3757,30 +3757,31 @@ var XPIDatabase = {
>  * @param  aName
>  *         An optional name for the add-on
>  * @param  aType
>  *         An optional type for the add-on
>  * @param  aIconURL
>  *         An optional icon for the add-on
>  * @param  aVersion
>  *         An optional version for the add-on
>- * @param  aInfoURL
>- *         An optional URL of release notes for the add-on
>+ * @param  aInfoURI
>+ *         An optional nsIURI of release notes for the add-on
As stated in bug 558834 - I think I'm ok with infoURI especially since it refers to updateInfoURL though I keep thinking that it should be releaseNoteURI. I leave that up to you.
Attachment #455267 - Flags: review?(robert.bugzilla) → review+
(Assignee)

Comment 3

9 years ago
(In reply to comment #2)
> (From update of attachment 455267 [details] [diff] [review])
> >diff --git a/toolkit/mozapps/extensions/XPIProvider.jsm b/toolkit/mozapps/extensions/XPIProvider.jsm
> >--- a/toolkit/mozapps/extensions/XPIProvider.jsm
> >+++ b/toolkit/mozapps/extensions/XPIProvider.jsm
> >@@ -3757,30 +3757,31 @@ var XPIDatabase = {
> >  * @param  aName
> >  *         An optional name for the add-on
> >  * @param  aType
> >  *         An optional type for the add-on
> >  * @param  aIconURL
> >  *         An optional icon for the add-on
> >  * @param  aVersion
> >  *         An optional version for the add-on
> >- * @param  aInfoURL
> >- *         An optional URL of release notes for the add-on
> >+ * @param  aInfoURI
> >+ *         An optional nsIURI of release notes for the add-on
> As stated in bug 558834 - I think I'm ok with infoURI especially since it
> refers to updateInfoURL though I keep thinking that it should be
> releaseNoteURI. I leave that up to you.

Went with releaseNotesURI throughout, I agree it makes more sense.
(Assignee)

Comment 4

9 years ago
Landed: http://hg.mozilla.org/mozilla-central/rev/05dd984bb0df
Status: ASSIGNED → RESOLVED
blocking2.0: --- → beta2+
Last Resolved: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.3b2
(Assignee)

Updated

9 years ago
Duplicate of this bug: 575818
Verified fixed based on the check-in and passing automated tests. I can't verify this manually until we have the update pane and a link available.
Status: RESOLVED → VERIFIED
Flags: in-testsuite+
Flags: in-litmus-
Keywords: APIchange
OS: Mac OS X → All
Hardware: x86 → All
Whiteboard: [AddonsRewrite][apichange][schemachange] → [AddonsRewrite][schemachange]
You need to log in before you can comment on or make changes to this bug.