Glass window border is fractured and lacks control buttons with lightweight theme enabled

RESOLVED DUPLICATE of bug 574833

Status

()

Firefox
Theme
RESOLVED DUPLICATE of bug 574833
8 years ago
8 years ago

People

(Reporter: Shawn Thompson, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:2.0b2pre) Gecko/20100630 Minefield/4.0b2pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:2.0b2pre) Gecko/20100630 Minefield/4.0b2pre

Ever since the titlebar drawing for the menu was added, personas in Vista and 7's Glass mode do not render correctly, the border is fractured and there are no control buttons visible, yet the titlebar area is still draggable.

Reproducible: Always

Steps to Reproduce:
1.Run in Aero Glass mode and turn on a persona.
Actual Results:  
The border is fractured and the control buttons do not appear.

Expected Results:  
The titlebar should still be present somehow, either still as a usual glass window border or as part of the background somehow.

This happened after the addition of the titlebar drawing functionality.
(Reporter)

Comment 1

8 years ago
Created attachment 455370 [details]
Screenshot
(Reporter)

Updated

8 years ago
Summary: Lightweight themes do not render correctly in Glass mode → Glass window border does not render correctly with lightweight theme
(Reporter)

Updated

8 years ago
Summary: Glass window border does not render correctly with lightweight theme → Glass window border is fractured and lacks control buttons with lightweight theme enabled

Comment 2

8 years ago
also, bug 575406
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 574833
You need to log in before you can comment on or make changes to this bug.