</textarea> incorrect close textarea field

RESOLVED INVALID

Status

--
critical
RESOLVED INVALID
9 years ago
8 years ago

People

(Reporter: xaviermd, Unassigned)

Tracking

unspecified
x86_64
Linux

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686 (x86_64); fr; rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6
Build Identifier: 

I used Bespin (0.8) to enrich a textarea field. The whole edited code inside the textarea is html escaped (ie < >). But if a </textarea> occurs in the text, the field is inccorectly closed by Bespin, and the remaining value show in the DOM.

Reproducible: Always

Steps to Reproduce:
1.link to Bespin an textarea
2.Inside <textarea> , put « &lt;textarea&gt; not there &lt;/textarea&gt; incorrectly outted text »
3. load the page
Actual Results:  
«incorrectly outted text» is outside the bespin editor

Expected Results:  
Bespin should have rendered
« <textarea> not there </textarea> incorrectly outted text »

Updated

9 years ago
Target Milestone: --- → 0.9
(Reporter)

Comment 1

8 years ago
A very BIG SORRY. after re-installation, the problem was coming that we desactivated htmlization of the textarea content when we put it for Bespin.

The reason was that we replace CR by <br /> when we escape html content for <texarea>.
so that a
«
<p>
hello
</p>
»
is escaped as

«
&lt;p&gt;<br />
hello<br />
&lt;/p&gt;<br />
»

But Bespin will consider that "<br />" should be displayed and not interpretated, instead of the standard textarea behaviour, as this :

«
<p><br />
hello<br />
</p><br />
»

This is not a critical issue but a minor one.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.