Unwanted extra space before the first word on the first line if I send any email message as plain text

RESOLVED DUPLICATE of bug 564737

Status

--
minor
RESOLVED DUPLICATE of bug 564737
8 years ago
8 years ago

People

(Reporter: chris, Unassigned)

Tracking

x86
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.4) Gecko/20100608 Thunderbird/3.1

For any mail message (new or reply) that I write, there is an unwanted extra space added before the first word on the first line.

For example, in the Write Message window, I type this

> Dear Gates,
>
> Today, I bought Windows and I cried.
>
> Chris

On the receiving end, I would see something like this:

>  Dear Gates,
>
> Today, I bought Windows and I cried.
>
> Chris

Notice the extra space before "Dear"? This makes the first line look mis-aligned and unprofessional :(

(I'm filing this as Minor instead of Trivial because it's basically a showstopper for use in corporate settings where things need to look professional. IMO this is more than just a trivial problem that affects the user itself. The workaround I suggested below is also not easy for home users to figure out)


Reproducible: Always

Steps to Reproduce:
1. Install Thunderbird on a fresh Windows machine (yes, I had to list this step because I tried a fresh install just to prove that I didn't touch any other configuration)
2. Set up SMTP server
3. Ctrl+N to write a new message. Type the example message described in Details.
4. Open the email on the receiving end

Actual Results:  
>  Dear Gates,
>
> Today, I bought Windows and I cried.
>
> Chris

Expected Results:  
> Dear Gates,
>
> Today, I bought Windows and I cried.
>
> Chris

I tried this on both Windows 7 Ultimate x64 and Windows XP Pro x86 (in VirtualBox).

I could temporarily "solve" this problem by adding a "<strong>&nbsp;</strong>" at my custom HTML signature file so that the message would be forced to sent in HTML mode automatically. (Ticking "Compose messages in HTML format" doesn't always do the trick since Thunderbird sometimes like to get smart and detect that I don't have any HTML constructs and send a plain text version instead, but that's another issue)

In fact, when I inspected the "source code" of the messages both in HTML mode and in plain text mode, I realized there was still this extraneous space before the first word, but it's just that when things are sent in HTML mode, email clients tend to ignore whitespaces before the first word so it would appear "correct."
(Reporter)

Updated

8 years ago
Version: unspecified → 3.1
(Reporter)

Comment 1

8 years ago
(Reminder to self in-case I'd patch it)

bwinto from IRC suggested this file to start looking for the problem:

http://mxr.mozilla.org/comm-central/source/mail/components/compose/content/MsgComposeCommands.js#1873

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 564737
You need to log in before you can comment on or make changes to this bug.