crash on startup while converting ~/.netscape to ~/.mozilla

CLOSED WORKSFORME

Status

Core Graveyard
Profile: Migration
P3
major
CLOSED WORKSFORME
17 years ago
2 years ago

People

(Reporter: Andreas J. Koenig, Assigned: dbragg)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
This Mozilla is built from CVS as of today (tried yesterday too)
Reproducability: always
Profile: I have no ~/.mozilla directory but a ~/.netscape directory (from 4.75).

When I start Mozilla, a window appears saying "You are about to create a Mozilla
profile based on your Netscape 4 profile...." and offers "Convert Profile" and
"Manage Profiles" as options.

If I press either of the two buttons, Mozilla immediately crashes. The last
words are:


IsPluginFile(/home/k/bin/moz/mozilla-20001012/mozilla/modules/plugin/default/unix/libnullplugin.so)
LoadPlugin()
/home/k/bin/moz/mozilla-20001012/mozilla/modules/plugin/default/unix/libnullplugin.so
returned 41124b50
debug: edburns ns4xPlugin::CreatePlugin
debug: edburns ns4xPlugin::CreatePlugin: cleared callbacks
debug: edburns: ns4xPlugin::CreatePlugin: callbacks->newstream: 0x410ecc48
plugin getvalue 1 called
plugin getvalue 2 called
plugin getmimedescription called
GetMIMEDescription() returned "*:.*:All types"
Registering plugin for: "*","All types",".*"
Note: verifyreflow is disabled
Note: styleverifytree is disabled
WARNING: waaah!, file nsXULPrototypeDocument.cpp, line 523
JavaScript strict warning: 
chrome://communicator/content/profile/confirmMigration.js line 51: function
onLoad does not always return a value

Note: frameverifytree is disabled
Move window by 511.5,383.5


A few words about the history of this build: I did move the whole build tree
from one machine to another, pretty identical machine. I did run a 'gmake -f
client.mk clean' followed by a 'gmake -f client.mk build'.

I'll try to get a stack trace and attach it. I'll also try to hide my
~/.netscape directory and report later.
(Reporter)

Comment 1

17 years ago
After hiding my ~/.netscape, I got Mozilla running but it crashed preet soon
when I tried to visit this bugzilla page. This makes me believe that some other
dependency is not fulfilled on this machine and I'll have to study the page
about prerequisites once again. Any advice appreciated.
(Reporter)

Comment 2

17 years ago
I have checked all prerequisites and my box has them all, so no
insight from that front. Instead, I still see the SEGV described above
and now I also have the stack trace, I hope it helps somebody. I'm
setting the crash keyword too.


#0  0x403bcaf2 in _IO_fputs (
    str=0x411fe520 "nsWidget::~nsWidget() of toplevel: 1 widgets still exist.\n"
, fp=0x40458c60) at iofputs.c:39
#1  0x40983834 in g_print (
    format=0x4081da00 "nsWidget::~nsWidget() of toplevel: %d widgets still exist
.\n") at gmessages.c:660
#2  0x407df01e in nsWidget::~nsWidget (this=0x8129518, __in_chrg=3)
    at nsWidget.cpp:341
#3  0x407e690a in nsWindow::~nsWindow (this=0x8129518, __in_chrg=3)
    at nsWindow.cpp:206
#4  0x407f2d82 in nsBaseWidget::Release (this=0x8129518) at nsBaseWidget.cpp:45
#5  0x407df1ce in nsWidget::Release (this=0x8129518) at nsWidget.cpp:352
#6  0x407e669e in nsWindow::Release (this=0x8129518) at nsWindow.cpp:134
#7  0x4076c496 in nsCOMPtr<nsIWidget>::assign_assuming_AddRef (this=0x8164118, 
    newPtr=0x0) at ../../../dist/include/nsCOMPtr.h:471
#8  0x4076c4e4 in nsCOMPtr<nsIWidget>::assign_with_AddRef (this=0x8164118, 
    rawPtr=0x0) at ../../../dist/include/nsCOMPtr.h:848
#9  0x40770dab in nsCOMPtr<nsIWidget>::operator= (this=0x8164118, rhs=0x0)
    at ../../../dist/include/nsCOMPtr.h:583
#10 0x4074b97a in nsXULWindow::Destroy (this=0x81640f0) at nsXULWindow.cpp:351
#11 0x4075829e in nsWebShellWindow::Destroy (this=0x81640f0)
    at nsWebShellWindow.cpp:1749
#12 0x407475c7 in nsChromeTreeOwner::Destroy (this=0x819ace8)
    at nsChromeTreeOwner.cpp:216
#13 0x40554c88 in GlobalWindowImpl::Close (this=0x411227f0)
    at nsGlobalWindow.cpp:2036
#14 0x4055c65b in GlobalWindowImpl::CloseWindow (aWindow=0x411227f0)
    at nsGlobalWindow.cpp:3525
#15 0x405382a1 in nsJSContext::ScriptEvaluated (this=0x411282a8, aTerminated=1)
    at nsJSEnvironment.cpp:1295
#16 0x40537736 in nsJSContext::CallEventHandler (this=0x411282a8, 
    aTarget=0x4119eed8, aHandler=0x4119f170, argc=1, argv=0xbfffdf98, 
    aBoolResult=0xbfffdee8, aReverseReturnResult=0) at nsJSEnvironment.cpp:912
#17 0x4058befc in nsJSEventListener::HandleEvent (this=0x41168ab0, 
    aEvent=0x41fce9d4) at nsJSEventListener.cpp:154
#18 0x4152852c in nsEventListenerManager::HandleEventSubType (this=0x41168a58, 
    aListenerStruct=0x41168ad8, aDOMEvent=0x41fce9d4, 
    aCurrentTarget=0x411800c0, aSubType=4, aPhaseFlags=7)
    at nsEventListenerManager.cpp:788
#19 0x41528d35 in nsEventListenerManager::HandleEvent (this=0x41168a58, 
    aPresContext=0x41122558, aEvent=0xbfffec2c, aDOMEvent=0xbfffeacc, 
    aCurrentTarget=0x411800c0, aFlags=7, aEventStatus=0xbffff0b0)
    at nsEventListenerManager.cpp:935
#20 0x40bbfcba in nsXULElement::HandleDOMEvent (this=0x411800b8, 
    aPresContext=0x41122558, aEvent=0xbfffec2c, aDOMEvent=0xbfffeacc, 
    aFlags=1, aEventStatus=0xbffff0b0) at nsXULElement.cpp:3304
#21 0x4159c957 in PresShell::HandleEventInternal (this=0x41184968, 
    aEvent=0xbfffec2c, aView=0x0, aFlags=1, aStatus=0xbffff0b0)
    at nsPresShell.cpp:4916
#22 0x4159c830 in PresShell::HandleEventWithTarget (this=0x41184968, 
    aEvent=0xbfffec2c, aFrame=0x41f6a998, aContent=0x411800b8, aFlags=1, 
    aStatus=0xbffff0b0) at nsPresShell.cpp:4897
#23 0x41533db1 in nsEventStateManager::CheckForAndDispatchClick (
    this=0x41f4bfb0, aPresContext=0x41122558, aEvent=0xbffff1b4, 
    aStatus=0xbffff0b0) at nsEventStateManager.cpp:1863
#24 0x41531129 in nsEventStateManager::PostHandleEvent (this=0x41f4bfb0, 
    aPresContext=0x41122558, aEvent=0xbffff1b4, aTargetFrame=0x41f6a998, 
    aStatus=0xbffff0b0, aView=0x41184458) at nsEventStateManager.cpp:940
#25 0x4159cabc in PresShell::HandleEventInternal (this=0x41184968, 
    aEvent=0xbffff1b4, aView=0x41184458, aFlags=1, aStatus=0xbffff0b0)
    at nsPresShell.cpp:4936
#26 0x4159c56a in PresShell::HandleEvent (this=0x41184968, aView=0x41184458, 
    aEvent=0xbffff1b4, aEventStatus=0xbffff0b0, aForceHandle=1, 
    aHandled=@0xbffff054) at nsPresShell.cpp:4851
#27 0x41c186fb in nsView::HandleEvent (this=0x41184458, event=0xbffff1b4, 
    aEventFlags=28, aStatus=0xbffff0b0, aForceHandle=1, aHandled=@0xbffff054)
    at nsView.cpp:366
#28 0x41c234f5 in nsViewManager2::DispatchEvent (this=0x411841e0, 
    aEvent=0xbffff1b4, aStatus=0xbffff0b0) at nsViewManager2.cpp:1437
#29 0x41c17d64 in HandleEvent (aEvent=0xbffff1b4) at nsView.cpp:67
#30 0x407e1588 in nsWidget::DispatchEvent (this=0x41184518, aEvent=0xbffff1b4, 
    aStatus=@0xbffff14c) at nsWidget.cpp:1483
#31 0x407e11cc in nsWidget::DispatchWindowEvent (this=0x41184518, 
    event=0xbffff1b4) at nsWidget.cpp:1374
#32 0x407e1640 in nsWidget::DispatchMouseEvent (this=0x41184518, 
    aEvent=@0xbffff1b4) at nsWidget.cpp:1510
#33 0x407e28e5 in nsWidget::OnButtonReleaseSignal (this=0x41184518, 
    aGdkButtonEvent=0x81b33a8) at nsWidget.cpp:2044
#34 0x407e8de0 in nsWindow::HandleGDKEvent (this=0x41184518, event=0x81b33a8)
    at nsWindow.cpp:1416
#35 0x407d8f1d in dispatch_superwin_event (event=0x81b33a8, window=0x41184518)
    at nsGtkEventHandler.cpp:981
#36 0x407d8b74 in handle_gdk_event (event=0x81b33a8, data=0x0)
    at nsGtkEventHandler.cpp:828
#37 0x40956b1e in gdk_event_dispatch (source_data=0x0, 
    current_time=0xbffff3f4, user_data=0x0) at gdkevents.c:2105
#38 0x40980b4f in g_main_dispatch (current_time=0xbffff3f4) at gmain.c:656
#39 0x40981137 in g_main_iterate (block=1, dispatch=1) at gmain.c:874
#40 0x409812b9 in g_main_run (loop=0x81b3338) at gmain.c:932
#41 0x408b65c7 in gtk_main () at gtkmain.c:476
#42 0x407cde5a in nsAppShell::Run (this=0x80adb08) at nsAppShell.cpp:335
#43 0x407523d4 in nsAppShellService::Run (this=0x80b3988)
    at nsAppShellService.cpp:407
#44 0x40ca41c2 in nsProfile::LoadDefaultProfileDir (this=0x8166f60, 
    profileURLStr=@0xbffff614) at nsProfile.cpp:444
#45 0x40ca3c80 in nsProfile::StartupWithArgs (this=0x8166f60, 
    cmdLineArgs=0x80ad0a8) at nsProfile.cpp:365
#46 0x805520c in InitializeProfileService (cmdLineArgs=0x80ad0a8)
    at nsAppRunner.cpp:812
#47 0x8055d04 in main1 (argc=3, argv=0xbffff964, nativeApp=0x0)
    at nsAppRunner.cpp:981
#48 0x805695a in main (argc=3, argv=0xbffff964) at nsAppRunner.cpp:1261
(gdb) 
Keywords: crash
(Reporter)

Comment 3

17 years ago
I fetched the complete sources from CVS once again into a new directory. The bug
remains, so we can assert, it's not stemming from broken sources. My workaround
is easy: I hide my ~/.netscape directory when starting up Mozilla for the first
time. As soon as I have a ~/.mozilla/ directory, I can make the ~/.netscape
directory available again. But I'm still not happy about this Mozilla build, it
soon cores again and is no fun to use. I'm not sure if I should file more
bugreports or wait a few days.

Anyway I'm changing Summary to more clearly describe the problem.
Summary: Mozilla crashes on startup → crash on startup while converting ~/.netscape to ~/.mozilla

Comment 4

17 years ago
Reassigning to the Profile Migration group.
Assignee: cls → dbragg
Component: Build Config → Profile Migration
QA Contact: granrose → gbush

Comment 5

17 years ago
Andreas J. Koenig, have you tried one of the binaries provided at
ftp://ftp.mozilla.org/pub/mozilla/nightly/ ?
(Reporter)

Comment 6

17 years ago
No, I haven't tried nightlies. If you want me to do so, plese tell me which
files to download and how to proceed exactly. I do not know the difference
between mozilla-i686-pc-linux-gnu-sea.tar.gz and
mozilla-i686-pc-linux-gnu.tar.gz, I do not know if I need
mozilla-i686-pc-linux-gnu-installer.tar.gz and what to do after downloading. I
seem to have failed locating a concise document dealing with these questions.

Comment 7

17 years ago
Migration of profiles works for me. Andreas, please test with the installer - 
mozilla-i686-pc-linux-gnu-installer.tar.gz
After you download the file, type "gunzip mozilla-i686*"
Then, type "tar -xvf mozilla-i686*"
Change to the new directory created, and run mozilla-installer.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
QA Contact: gbush → junruh
Resolution: --- → WORKSFORME
(Reporter)

Comment 8

17 years ago
Oh my, a can of worms. Nothing seems to work as it should:-(

First I did as requested. The resulting /usr/local/mozilla/mozilla binary
behaved a little better than the self compiled. At least I could visit this page
and type something into this bugzilla comment field. I did quit this Mozilla and
tried starting the self-compiled mozilla from yesterday's CVS sources. The
self-compiled started up and crashed when I visited this bug page. Please note,
that this is better than it was before, at least it lived a bit longer than the
startup phase. I then started up the /usr/local/mozilla/mozilla again but it
crashed when I stopped it with ^Z and started it again with fg. Talkback agent
appeared. I then filed a talkback bugreport but I believe even talkback crashed,
at least it didn't confirm after pushing the Send button, it disappeared very
quickly. So I lost the bugreport I had been typing in, but I didn't give up. I
started up /usr/local/mozilla/mozilla again and typed in the bugreport again but
when I clicked Commit button, Mozilla did not do anything, just the following on
the console:

Error loading URL http://bugzilla.mozilla.org/process_bug.cgi: 80004005 

Nothing more. I'm now using Netscape 4.76 to file this bugreport. To top all the
fun I had so far, I just copy'n'pasted the Error message above from the xterm to
this window and the Mozilla instance crashed again and now a fullcircle window
is awaiting me. Hold on a sec, I finish the Talkback dialog [...time passes...]
As before, Talkback agent immediately disappears after I press Send, looks like
a crash, not like normal behaviour.

Please make suggestions what I should try next. Obviously I should remove
~/.mozilla once again and just run the binary for a while, not even come close
to the self compiled. But why?
(Reporter)

Comment 9

17 years ago
Testing the downloaded binary /usr/local/mozilla/mozilla after ~/.mozilla was
removed completely. It offered conversion of the ~/.netscape to ~/.mozilla but
the window was ugly, it had no buttons, just text. I could click on the text and
the conversion succeeded. I could ^Z and fg several times without a crash. I
commit now and try more things.
(Assignee)

Comment 10

17 years ago
This is really looking less and less like a migration problem and more like a
system problem.  Andreas, you seem to be having serious problems with the
program even when you don't migrate your old profile.  Is that true?
(Reporter)

Comment 11

17 years ago
Yes, this is true, and I begin to think like you, but what could it be? Maybe we
should take a step back and remember that often only the first error is
relevant. Let's probably focus on the startup of this Mozilla. Is this the
output you would expect when neither a ~/.mozilla nor a ~/.netscape exists:

% /usr/local/mozilla/mozilla
/usr/local/mozilla/run-mozilla.sh /usr/local/mozilla/mozilla-bin
MOZILLA_FIVE_HOME=/usr/local/mozilla
  LD_LIBRARY_PATH=/usr/local/mozilla
     LIBRARY_PATH=/usr/local/mozilla:/usr/local/mozilla/components
       SHLIB_PATH=/usr/local/mozilla
          LIBPATH=/usr/local/mozilla
       ADDON_PATH=/usr/local/mozilla
      MOZ_PROGRAM=/usr/local/mozilla/mozilla-bin
      MOZ_TOOLKIT=
        moz_debug=0
     moz_debugger=
ProfileManager : CreateNewProfile
Profile Name: default
Profile Dir: /home/k/.mozilla
 I am inside the initialize
 Hey : You are in QFA Startup 
(QFA)Talkback loaded Ok.
XML Error in file 'chrome://global/locale/builtinURLs.rdf', Line Number: 29, Col
 Number: 68, Description: mismatched tag
Source Line:     <NC:contenth>http://home.netscape.com/bookmark/6_0/tstart.html<
/NC:content>
Setting content window

Any suggestions what I should try out welcome.
(Reporter)

Comment 12

17 years ago
No need to WFM, the bug can be closed. It is a duplicate or rather a parent of
bug 59835. Apologies for bothering the Profile Migration Departement.
Status: RESOLVED → CLOSED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.