Set MOZ_NO_REMOTE to 1 for 64-bit version to allow 32-bit and 64-bit FF to run simultaneously

RESOLVED WONTFIX

Status

()

Firefox
Build Config
RESOLVED WONTFIX
8 years ago
8 years ago

People

(Reporter: Scoobidiver (away), Unassigned)

Tracking

Trunk
x86_64
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; Win64; x64; en-US; rv:2.0b2pre) Gecko/20100701 Minefield/4.0b2pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; Win64; x64; en-US; rv:2.0b2pre) Gecko/20100701 Minefield/4.0b2pre

Both minefield (x86 and x86_64) are installed in two different directories and a Minefield x86 is running.
A double click on minefield x86_64 icon is opening a minefield x86 window instead of a minefield x86_64 one.
The contrary is also valid :  A double click on minefield x86 icon is opening a minefield x86_64 window instead of a minefield x86 one while Minefield x86_64 is running.

Reproducible: Always
Both installations of Minefield are trying to use the same profile, so the second one you try to start sees the profile is in use and switches to the instance of Minefield already running.

See http://support.mozilla.com/en-US/kb/Managing+profiles
and http://forums.mozillazine.org/viewtopic.php?f=23&t=1062975&start=0
for info on managing profiles and running two versions of Firefox simultaneously.

Pleas backup your profile too.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

8 years ago
Using an running two versions of Firefox are different.
I used the current version of firefox, the 32-bit minefield and a 64-bit minefield with different profiles. The minefield profiles were created from scratch and are regularly deleted and created again.

No problem when I run either firefox, or 32-bit minefield, or 64-bit minefield.
But when I try to run simultaneously 32-bit minefield AND 64-bit minefield, it is not possible (it is possible with 32-bit and 64-bit internet explorer 8 and lot of others applications with 32-bit and 64-bit versions).

By using double click on icon or by using the cmd.exe with "firefox.exe -P", a new window of the current minefield is opened.

This bug should be reopened.

Comment 3

8 years ago
Are You sure both Minefields are installed in separate directories. If so, could You write exact paths in Your system (though, it may be irrelevant).
(Reporter)

Comment 4

8 years ago
After comment 3, I tried to uninstall properly the two versions of Minefield. Only one was present in the uninstall window, the 64-bit version : Uninstallation succeeded.
In order to uninstall the 32-bit version, I installed it again and then I uninstalled it. I deleted the remaining directory.

From the ftp mozilla server, I reinstalled the 64-bit version in "C:\Program files\minefield" and the 32-bit version in "C:\Program files (x86)\minefield"
There is always only one entry in the uninstall window : the 64-bit version.

The bug is still present.
Sorry for not replying sooner.

I'm reopening based on comment 2 where, if I understand correctly, you state that you are trying to open the the second version of Minefield with "firefox.exe -P". The process you describe in comment 0 - doubleclicking on icons - would not normally use a different profiles. Have you created a shortcut to those executables with different profile names specified in the command line? If not, please try that.

Also, can you clarify whether you are able to run Firefox and Minefield (either 32bit or 64 bit) simultaneously?
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: INVALID → ---
(Reporter)

Comment 6

8 years ago
I use the -P option once and I unclick "Don't ask me at startup"
So for any FF or minefield version, the icon double click launches the profile manager.
I have one profile per version.

Here below are the results of my investigation which is more exhaustive than in the previous comment :
	Opened browser	  Browser launch		Launch results	
1.	FF 3.6	     	     FF 3.6			New FF 3.6 window
2.	FF 4.0b2	     FF 4.0b2			New FF 4.0b2 window
3.	FF 3.6	     	     FF 4.0b2			No new window
4.	FF 4.0b2	     FF 3.6		        No new window
5.	Minefield x86 	     Minefield x86              New minefield x86 window
6.	FF 3.6	     	     Minefield x86              No new window
7.	Minefield x86 	     FF 3.6                     New minefield x86 window
8.	Minefield x64 	     Minefield x64		New minefield x64 window
9.	FF 3.6	     	     Minefield x64		No new window
10.	Minefield x64 	     FF 3.6			New minefield x64 window
11.	Minefield x86 	     Minefield x64		New minefield x86 window
12.	Minefield x64 	     Minefield x86		New minefield x64 window

The results 7, 10, 11, 12 are incoherent.
If the results 1, 2, 5, 8 are the expected one (new window), then the results 3, 4, 6, 9 are incoherent (no new window).
If the results 3, 4, 6, 9 are the expected one (no new window), then the results 1, 2, 5, 8 are incoherent (new window).
(Reporter)

Comment 7

8 years ago
I added the "-no-remote" option to all my shortcut.
Now, every versions can run simultaneously.

The "-no-remote" option is safe for a beta tester when there are current and dev versions.
But with two possible current versions (32-bit, 64-bit) that use a shared profile, does a normal user add the "-no-remote" option to his shortcut ?
Should every FF be compiled with the NO_REMOTE flag ? only 64-bit versions ?
(Reporter)

Updated

8 years ago
Component: General → Build Config
OS: Windows 7 → All
QA Contact: general → build.config
Summary: Minefield x86 window is opening when clicking on minefield x86_64 icon while a minefield x86 is already running → Set MOZ_NO_REMOTE to 1 for 64-bit version to allow 32-bit and 64-bit FF to run simultaneously
Version: unspecified → Trunk

Comment 8

8 years ago
No. Non-testers don't care, and we should remote by default.
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.