Closed Bug 576554 Opened 10 years ago Closed 10 years ago

Need manifests to register XPCOM components on trunk

Categories

(Firefox :: Sync, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: philikon, Assigned: philikon)

References

Details

Attachments

(2 files, 1 obsolete file)

With bug 568691, XPCOM components now need manifests to be registered. services/ was fixed on mozilla-central in http://hg.mozilla.org/mozilla-central/rev/05b326ca0396. It would be good to replicate this in fx-sync as not to have diverging codebases.
Provide manifest files for JS-based components to match what has landed on mozilla-central already (http://hg.mozilla.org/mozilla-central/rev/05b326ca0396) and declare NSGetFactory when possible. Amend chrome.manifest for the add-on case.

Note that extensions no longer can observe app-startup (https://developer.mozilla.org/en/XPCOM/XPCOM_changes_in_Gecko_2.0#Extension_components_are_started_later) which we do in Weave.js. We don't do anything vital for the add-on there, though. The call to addResourceAlias() is only relevant when integrated into the app and the final-ui-startup observer is quite pointless IMHO since the app's XUL overlays already import service.js anyway. I think we should get rid of that code, leaving WeaveService only to add the resource alias in the non-addon case.
Assignee: nobody → philipp
Attachment #455783 - Flags: review?(mconnor)
Minor update: Use trailing slash for the resource alias to match what bug 576689 does.
Attachment #455783 - Attachment is obsolete: true
Attachment #455826 - Flags: review?(mconnor)
Attachment #455783 - Flags: review?(mconnor)
Attachment #455826 - Flags: review?(mconnor) → review+
Blocks: 576376
part 3 on 1.4.x branch (not landed on default yet): http://hg.mozilla.org/services/fx-sync/rev/bc05c7027b61
Duplicate of this bug: 576689
Are there parts of this bug that still need to land on m-c?
(In reply to comment #7)
> Are there parts of this bug that still need to land on m-c?

No. Even though part 2 and 3 haven't even made the fx-sync default branch yet, they're completely add-on specific. As far as m-c is concerned this is fixed.
Attachment #455886 - Flags: review?(edilee)
Comment on attachment 455886 [details] [diff] [review]
part 2: fix addonglue/aboutweavetabs/accidental commit of some monkeying

>+++ b/addon/AddonGlue.js
> 
For the other components, we have "// Gecko <2.0" here 
> function NSGetModule(compMgr, fileSpec) {
>   return XPCOMUtils.generateModule([AddonGlue]);
> }
>+// Gecko >=2.0

>+++ b/ui/firefox/AboutWeaveTabs.js
> 
> function NSGetModule(compMgr, fileSpec) {
Here too
Attachment #455886 - Flags: review?(edilee) → review+
Duplicate of this bug: 576376
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
No longer blocks: 576376
Component: Firefox Sync: Backend → Sync
Product: Cloud Services → Firefox
You need to log in before you can comment on or make changes to this bug.