Closed Bug 576561 Opened 11 years ago Closed 11 years ago

Browser window unable to focus while Java Applet Host is running

Categories

(Core :: Plug-ins, defect)

x86
macOS
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 563768

People

(Reporter: aaronmt, Unassigned)

References

()

Details

(Whiteboard: [Fx4Beta1Testday] [4b1])

Currently, on the latest trunk nightly when visiting the aforementioned URL, the Java Applet Host will open and it will retain focus, disallowing any control of the primary browser window besides scrolling.

STR:
1. Visit URL http://www.cs.ubc.ca/~harrison/Java/sorting-demo.html
2. See Java Applet Host open
3. Try to regain focus of the browser window, and notice the menubar

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:2.0b2pre) Gecko/20100702 Minefield/4.0b2pre
Summary: Browser window unable to focus when running Java Applet Host → Browser window unable to focus while Java Applet Host is running
This doesnt reproduce on Namoroka nightlies, so leads me to believe its OOPP related.
Reproduced issue.

Work around for now is to kill the java process.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 563768
Whiteboard: [fx4beta1testday] → [4b1]
Whiteboard: [4b1] → [Fx4Beta1Testday] [4b1]
You need to log in before you can comment on or make changes to this bug.