Closed Bug 576568 Opened 10 years ago Closed 10 years ago

[ACR Extension] Update Compatibility Reporter for XPCOM component registration changes

Categories

(addons.mozilla.org Graveyard :: Compatibility Tools, defect)

ACR-0.*
x86
All
defect
Not set
major

Tracking

(Not tracked)

RESOLVED FIXED
ACR-0.*

People

(Reporter: jruderman, Assigned: kinger)

References

Details

The "Add-on Compatibility Reporter" extension is busted on trunk.  It spews stuff like "acr(1): Invalid pref: addons" to my console and can't submit reports.

There was a change to XPCOM registration this week, and ACR has a JS XPCOM component, so the extension probably just needs the mechanical tweak:
https://developer.mozilla.org/en/XPCOM/XPCOM_changes_in_Gecko_1.9.3

I have:
* Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:2.0b2pre) Gecko/20100701 Firefox/4.0b2pre
* ACR 0.5
(In reply to comment #0)
> The "Add-on Compatibility Reporter" extension is busted on trunk.  It spews
> stuff like "acr(1): Invalid pref: addons" to my console and can't submit
> reports.

This looks more like bug 576492. I'm seeing the same problem in other extensions (default prefs aren't there).
Indeed, now that bug 576492 is fixed, the console noise is gone and I can submit compatibility reports.

The JS XPCOM component seems to be entirely about disabling EM compatibility checks.  The mechanical change might not work there because of timing issues.
Hrm, Dave, does ACR hook into the EM in ways that are impossible now? Or does it use preferences to control compatibility checking behavior in the EM?
(In reply to comment #2)
> The JS XPCOM component seems to be entirely about disabling EM compatibility
> checks.  The mechanical change might not work there because of timing issues.

Can you elaborate a bit more what you mean here Jesse?
(In reply to comment #3)
> Hrm, Dave, does ACR hook into the EM in ways that are impossible now? Or does
> it use preferences to control compatibility checking behavior in the EM?

The latter. It just sets the following prefs (in v0.5) to false:

extensions.checkCompatibility
extensions.checkCompatibility.3.6b
extensions.checkCompatibility.3.6
extensions.checkCompatibility.3.6p
extensions.checkCompatibility.3.6pre"
extensions.checkCompatibility.3.7a
extensions.checkCompatibility.4.0b
extensions.checkCompatibility.4.0pre
extensions.checkCompatibility.4.0p

We do it on final-ui-startup.
"timing issues" -- the EM has already decided to load the ACR extension, so the ACR extension may have trouble influencing the EM's compatibility checks.
You set them as user prefs, or as default prefs? If user prefs, doesn't that persist beyond the uninstall of ACR? If default prefs, it wouldn't persist beyond the current session and therefore it seems that it would be useless.
(In reply to comment #6)
> "timing issues" -- the EM has already decided to load the ACR extension, so the
> ACR extension may have trouble influencing the EM's compatibility checks.

Right, see bug 572322 (which may well be a dupe of this). Basically a 2nd restart is required.

(In reply to comment #7)
> You set them as user prefs, or as default prefs? If user prefs, doesn't that
> persist beyond the uninstall of ACR? If default prefs, it wouldn't persist
> beyond the current session and therefore it seems that it would be useless.

It looks like these prefs are default, but somehow are not exposed as such, i.e. they don't appear in about:config before install. They do persist across sessions.

We do some cleanup when the add-on is uninstalled.
Fixed:
http://viewvc.svn.mozilla.org/vc?revision=71191&view=revision

Watch for it in an imminent 0.5.1 release.
Assignee: nobody → briks.si
Status: NEW → RESOLVED
Closed: 10 years ago
OS: Mac OS X → All
Resolution: --- → FIXED
Target Milestone: --- → ACR-0.*
(In reply to comment #10)
> 0.5.1 has been released:
> 
> https://addons.mozilla.org/en-US/firefox/addon/15003/versions/

...and still no SeaMonkey support <shrug />.
v0.5.1 is not compatible with Firefox 4.0b4 :-(
(In reply to comment #12)
> v0.5.1 is not compatible with Firefox 4.0b4 :-(

Should be now.
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.