[10.4] Browser chrome missing metal-style bezel on Tiger

RESOLVED WONTFIX

Status

()

Firefox
Shell Integration
--
trivial
RESOLVED WONTFIX
8 years ago
8 years ago

People

(Reporter: djordje.djukic, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6

Tiger's dark gradient metal style differs from later OS X versions in that it has a slight bezel running around the top and sides of the window. However, Firefox uses the Leopard/Snow Leo style which is missing this element.

This means that, application-wide, the titlebar containing the bezel joins the rest of the chrome which doesn't have it and the visual styles clash.

Reproducible: Always

Steps to Reproduce:
1. Run on Mac OS X 10.4, or:
2. disable the NSUseLeopardWindowValues global preference on 10.5 and run Firefox;
3. disable the NSUseLeopardWindowValues and AppleUseCoreUI global preferences on 10.6 and run Firefox.
Actual Results:  
The titlebar has a distinct native visual style as opposed to the rest of the window which looks like it came from Leopard, creating an ugly result which is especially noticeable on the Add-ons and Preferences windows.

Expected Results:  
A different style titlebar that matches the rest of the window (like Safari), or a Tiger style on -moz-mac-unified-toolbar (which causes the issue on all themes that use it) and the rest of the theme elements.

The issue occurs on all windows with a metal style, as long as the theme uses -moz-mac-unified-toolbar and disregards the bezel on the rest of the elements.
(Reporter)

Comment 1

8 years ago
Created attachment 455743 [details]
Results on b/w background

How the bug looks like on a black/white background, full-size
(Reporter)

Comment 2

8 years ago
Created attachment 455745 [details]
Screenshot of the issue, cropped

Cropped the problem area
Yeah, it looks a little bad, but we're not going to fix it. The next version of Firefox isn't going to support 10.4 and fixing it on the 3.6 branch isn't worth it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.