Add documentation to PHttpChannel.ipdl

RESOLVED WONTFIX

Status

()

Core
Networking: HTTP
RESOLVED WONTFIX
8 years ago
2 years ago

People

(Reporter: jduell, Assigned: jduell)

Tracking

(Blocks: 1 bug)

unspecified
x86
Windows Server 2003
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10s-, fennec-)

Details

(Whiteboard: [necko-backlog])

Attachments

(1 attachment)

Created attachment 455813 [details] [diff] [review]
Add documentation to PHttpChannel.ipdl

Add documentation to PHttpChannel.ipdl
Attachment #455813 - Flags: review?(bzbarsky)
(Assignee)

Updated

8 years ago
Blocks: 516730
Attachment #455813 - Attachment is patch: true
Attachment #455813 - Attachment mime type: application/octet-stream → text/plain

Comment 1

8 years ago
>+  // Sets 
>   SetCacheTokenCachedCharset(nsCString charset);

This could be improved.

>+  // This method is currently needed only to free the cache descriptor, which
>+  // we keep around in case SetCacheTokenCachedCharset messages arrive late
>+  // (i.e. after the nsHttpChannel's OnStopRequest has completed).  
>   OnStopRequestCompleted();

This no longer exists.
OS: Linux → Windows Server 2003
BTW, shouldn't we use /** */ doxygen style for comments?
Comment on attachment 455813 [details] [diff] [review]
Add documentation to PHttpChannel.ipdl

>+  // - When this message is sent, we are guaranteed to send OnStart/OnStop
>+  //   messages back to the child.

Shouldn't that comment start with "If this message is sent successfully"?

> +  // Sets 

Should there be more comment there?

r=me with those addressed.
Attachment #455813 - Flags: review?(bzbarsky) → review+

Updated

8 years ago
Assignee: nobody → jduell.mcbugs

Updated

8 years ago
Duplicate of this bug: 580451

Updated

8 years ago
Blocks: 575636
tracking-fennec: --- → ?

Comment 5

8 years ago
will not block fennec for this.
tracking-fennec: ? → 2.0-

Comment 6

8 years ago
Comment on attachment 455813 [details] [diff] [review]
Add documentation to PHttpChannel.ipdl

doc only change.  love docs.
Attachment #455813 - Flags: approval2.0+

Updated

8 years ago
Keywords: checkin-needed
You still need to address comment 3.
Keywords: checkin-needed
Comment on attachment 455813 [details] [diff] [review]
Add documentation to PHttpChannel.ipdl

not ready for checkin => not approved
Attachment #455813 - Flags: approval2.0+ → approval2.0-
Mass tracking-e10s flag change. Filter bugmail on "2be0fcce-e36a-4e2c-aa80-0e3d33eb5406".
tracking-e10s: --- → +
tracking-e10s: + → later
tracking-e10s: later → -
jason, please land this or wontfix it or something
Flags: needinfo?(jduell.mcbugs)
Whiteboard: [necko-backlog]
(Assignee)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(jduell.mcbugs)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.