crash upon start when using third party keyboard (swype)

VERIFIED FIXED

Status

--
major
VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: theglus, Unassigned)

Tracking

Trunk
ARM
Android

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.6) Gecko/20100625 Ant.com Toolbar 2.0.1 Firefox/3.6.6
Build Identifier: Fennec Nightly Build for Android July 1, 2010

On Android, if your default keyboard is set to a third party keyboard such as Swype, upon launching Fennec the fennec homepage will load but the phone will freeze for about 10 second making the phone inoperable until Android opens and error window saying "Sorry Activity Fennec (in application Fennec) is not responding" and the gives you the option to "force quit"or "wait".

Reproducible: Always

Steps to Reproduce:
1.Set Swype as default keyboard
2.Launch Fennec

Actual Results:  
1. The Fennec homepage loads
2. The phone freezes and becomes inoperable
3. Window saying "Sorry Activity Fennec (in application Fennec) is not responding" and the gives you the option to "force quit"or "wait"

Expected Results:  
Fennec should have loaded the homepage and allow use of the browser when third party keyboard such as Swype is in use.

I am using an HTC Incredible with Android 2.1 on it with the Sense UI and am using the current build of the Android third party keyboard known as Swype.
(Reporter)

Updated

8 years ago
OS: Other → Android
Hardware: Other → ARM
tracking-fennec: --- → 2.0+
Duplicate of this bug: 580038
Confirmed on Droid using Swype 1.56. This is similar to bug 580219 (that one is a different keyboard)

Swype works fine when you switch to it inside Fennec. However if you set your
keyboard to Swype before launching Fennec, Fennec will hang after startup.

The rewrite from bug 576065 does not seem to have this bug.
Severity: critical → major
Status: UNCONFIRMED → NEW
Depends on: 576065
Ever confirmed: true

Comment 3

8 years ago
I'm using a Samsung Captivate and the stock default keyboard is Swype. And every time I started up Fennec 25-Jul-2010 it would become unresponsive after loading the start page and require a force quit.

Changing the default keyboard to the Android keyboard is a workaround that worked.

Comment 4

8 years ago
It's not only Swype, it occurs with SwiftKey as well. Tested this on a Vanilla HTC Desire with original 2.1 firmware as well as a Desire running 2.2 OpenDesire. Sounds like there is a Problem with the recognition of third Party keyboards in general.

If you turn SwiftKey off, everything runs fine (for the early stages, we are in). If you turn it on, Fennec hangs himself into a state of unwillingness. No response at all.

Should be reproducable on any device.
Fixed by bug 576065
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED

Comment 6

8 years ago
Verified on:

Mozilla/5.0 (Android; Linux armv7l; rv:2.0b13pre) Gecko/20100307 Firefox/4.0b13pre Fennec/4.0b6pre
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.