Intermittent test_ctypes.xul | Worker had an error: too much recursion

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
9 years ago
7 years ago

People

(Reporter: philor, Unassigned)

Tracking

({intermittent-failure})

Trunk
x86
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1278200579.1278202104.21305.gz
Rev3 MacOSX Leopard 10.5.8 mozilla-central debug test mochitest-other on 2010/07/03 16:42:59
s: talos-r3-leopard-035

6576 INFO TEST-START | chrome://mochikit/content/chrome/toolkit/components/jsctypes-test/test_ctypes.xul
++DOMWINDOW == 61 (0x215c0a18) [serial = 704] [outer = 0x1e7d24e0]
6577 INFO TEST-PASS | chrome://mochikit/content/chrome/toolkit/components/jsctypes-test/test_ctypes.xul | Chrome test dir doesn't exist?!
6578 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/chrome/toolkit/components/jsctypes-test/test_ctypes.xul | Worker had an error: too much recursion
6579 INFO SimpleTest finished chrome://mochikit/content/chrome/toolkit/components/jsctypes-test/test_ctypes.xul in 251ms
bent, any idea what's up here? The ctypes xpcshell tests pass, so it's likely something up specifically with the worker bits.
So far it seems to be happening on mac debug only but I can't reproduce. No ideas really, something about the stack quotas maybe? Still investigating.
Any luck? What's the stack depth limit? The ctypes tests don't involve recursion but maybe there's something funky going on with closures?
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1281478175.1281479965.31163.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central debug test mochitest-other on 2010/08/10 15:09:35
s: talos-r3-snow-020

6575 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/chrome/toolkit/components/jsctypes-test/test_ctypes.xul | Worker had an error: too much recursion
philringnalda%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1281495458.1281497078.22861.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central debug test mochitest-other on 2010/08/10 19:57:38

s: talos-r3-snow-020
6575 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/chrome/toolkit/components/jsctypes-test/test_ctypes.xul | Worker had an error: too much recursion
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WORKSFORME
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.