XUL scrollbars not appearing on recent nightlies

VERIFIED DUPLICATE of bug 577076

Status

()

--
blocker
VERIFIED DUPLICATE of bug 577076
8 years ago
8 years ago

People

(Reporter: ShareBird, Unassigned)

Tracking

({regression})

Trunk
x86
Windows XP
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
Some themes use pure XUL scrollbars and have images to style them. On recent nightlies this scrollbars don't appear anymore. It seems to be a regression from Bug 576540
Do have a screenshot showing this?  That bug turned D2D back on for Windows after XPCom broke it.

Comment 2

8 years ago
Created attachment 455937 [details]
Walnut showing the problem: No arrows, no background, nothing in the scrollbar.

This is a serious regression, and impact all themes that not use 'native' appearance for scrollbars. This MUST be fixed before FF4 is released, otherwise millions of FF users will complain about themes no longer working.

Updated

8 years ago
Depends on: 576540

Comment 3

8 years ago
Are you sure this was bug 576540, and not bug 568691?
Yes this problem began with Changeset f9e9f951c0ab.
Created attachment 456001 [details]
Walnut theme scrollbars before and after

Confirming that the changeset mentioned shows bustage for this theme.  Scrollbar images were working fine in changeset e65442f37c01.

Pushlog between the two builds:
http://hg.mozilla.org/mozilla-central/pushloghtml?startdate=7%2F2%2F2010+13%3A22&enddate=7%2F2%2F2010+14%3A30

Updated

8 years ago
Blocks: 576540
blocking2.0: --- → ?
No longer depends on: 576540

Comment 6

8 years ago
Same issue with littlefox.
Walnut theme scrollbars is fixed with the bug 577076 checkin.  Dupe against that bug.

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 577076

Comment 9

8 years ago
Verified with Nautipolis with build Mozilla/5.0 (Windows; Windows NT 5.1; en-US; rv:2.0b2pre) Gecko/20100709 Minefield/4.0b2pre
Status: RESOLVED → VERIFIED

Updated

8 years ago
blocking2.0: ? → ---
You need to log in before you can comment on or make changes to this bug.